summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-09-19 15:37:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-09-19 15:37:33 +0000
commit3d1806f76c4635ca0277fdac7cde3d40de342b68 (patch)
treee110c94cf69f3af04b660601ae37a60dfb197b5e /media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
parentFix nx3support patch, closes bug #193031 (diff)
downloadhistorical-3d1806f76c4635ca0277fdac7cde3d40de342b68.tar.gz
historical-3d1806f76c4635ca0277fdac7cde3d40de342b68.tar.bz2
historical-3d1806f76c4635ca0277fdac7cde3d40de342b68.zip
add a patch wrt to buffer overflow possibility, bug #192834
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild b/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
new file mode 100644
index 000000000000..e93d1138b63c
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild,v 1.1 2007/09/19 15:37:32 aballier Exp $
+
+WANT_AUTOCONF=2.5
+WANT_AUTOMAKE=1.9
+
+inherit eutils libtool autotools
+
+DESCRIPTION="A C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+SRC_URI="http://www.mega-nerd.com/libsndfile/${P}.tar.gz
+ mirror://gentoo/${P}+flac-1.1.3.patch.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sqlite flac alsa"
+
+RESTRICT="test"
+
+RDEPEND="flac? ( media-libs/flac )
+ alsa? ( media-libs/alsa-lib )
+ sqlite? ( >=dev-db/sqlite-3.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${P}+flac-1.1.3.patch"
+ epatch "${FILESDIR}/${P}-ogg.patch"
+ epatch "${FILESDIR}/${P}-flac-buffer-overflow.patch"
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ econf $(use_enable sqlite) \
+ $(use_enable flac) \
+ $(use_enable alsa) \
+ --disable-werror \
+ --disable-gcc-pipe \
+ --disable-dependency-tracking || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" htmldocdir="/usr/share/doc/${PF}/html" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}