summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-25 05:37:55 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-25 05:37:55 +0000
commitd8413061d1177b1d91283def1cfb42eef97938e5 (patch)
tree9c0dd589ce24195a5ecc05fc9972f753c3a9a103 /media-libs/libvpx/libvpx-1.1.0.ebuild
parentStable on alpha, bug 435228. (diff)
downloadhistorical-d8413061d1177b1d91283def1cfb42eef97938e5.tar.gz
historical-d8413061d1177b1d91283def1cfb42eef97938e5.tar.bz2
historical-d8413061d1177b1d91283def1cfb42eef97938e5.zip
Initial x32 ABI support #426248 by devsk.
Package-Manager: portage-2.2.0_alpha131/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libvpx/libvpx-1.1.0.ebuild')
-rw-r--r--media-libs/libvpx/libvpx-1.1.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/libvpx/libvpx-1.1.0.ebuild b/media-libs/libvpx/libvpx-1.1.0.ebuild
index 63af80f2320d..496e47b384d8 100644
--- a/media-libs/libvpx/libvpx-1.1.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-1.1.0.ebuild,v 1.14 2012/08/16 23:03:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-1.1.0.ebuild,v 1.15 2012/09/25 05:37:55 vapier Exp $
EAPI=4
inherit multilib toolchain-funcs base
@@ -43,6 +43,7 @@ PATCHES=(
"${FILESDIR}/${P}-chost.patch"
"${FILESDIR}/${P}-generic-gnu-shared.patch"
"${FILESDIR}/${P}-arm.patch"
+ "${FILESDIR}/${P}-x32.patch"
)
src_configure() {
@@ -65,6 +66,7 @@ src_configure() {
# Link with gcc by default, the build system should override this if needed.
export LD="${CC}"
+ set -- \
./configure \
--prefix="${EPREFIX}"/usr \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
@@ -84,8 +86,9 @@ src_configure() {
$(use_enable sse4_1) \
$(use_enable ssse3) \
$(use_enable static-libs static ) \
- $(use_enable threads multithread) \
- || die
+ $(use_enable threads multithread)
+ echo "$@"
+ "$@" || die
}
src_install() {