summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-13 03:04:30 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-13 03:04:30 +0000
commit423be518899bed1d78588846821c5baae3860926 (patch)
tree7fabfd9e4438cd42fdb783572b0569a6520c64fd /media-libs/raptor/raptor-0.9.12.ebuild
parentInitial import, hard-masked (diff)
downloadhistorical-423be518899bed1d78588846821c5baae3860926.tar.gz
historical-423be518899bed1d78588846821c5baae3860926.tar.bz2
historical-423be518899bed1d78588846821c5baae3860926.zip
Added optional curl and ssl dependencies. Closes bug #34870.
Diffstat (limited to 'media-libs/raptor/raptor-0.9.12.ebuild')
-rw-r--r--media-libs/raptor/raptor-0.9.12.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/media-libs/raptor/raptor-0.9.12.ebuild b/media-libs/raptor/raptor-0.9.12.ebuild
index 76b5647d3d6d..7f03b5922fcd 100644
--- a/media-libs/raptor/raptor-0.9.12.ebuild
+++ b/media-libs/raptor/raptor-0.9.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-0.9.12.ebuild,v 1.3 2004/01/27 07:17:08 torbenh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-0.9.12.ebuild,v 1.4 2004/02/13 03:04:30 eradicator Exp $
DESCRIPTION="The RDF Parser Toolkit"
HOMEPAGE="http://www.redland.opensource.ac.uk/raptor/"
@@ -8,16 +8,20 @@ SRC_URI="http://www.redland.opensource.ac.uk/dist/source/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc"
-IUSE=""
+IUSE="curl"
DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )
+ curl? ( net-ftp/curl )
>=dev-libs/libxml2-2.4.24"
+
S=${WORKDIR}/${P}
-src_compile() {
- econf || die
- emake || die
-}
+DOC="AUTHORS COPYING COPYING.LIB ChangeLog INSTALL LICENSE.txt NEWS README"
+HTML="INSTALL.html LICENSE.html MPL.html NEWS.html README.html"
src_install() {
- einstall || die
+ make DESTDIR=${D} install || die
+
+ dodoc ${DOC}
+ dohtml ${HTML}
}