summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-31 11:51:16 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-31 11:51:16 +0000
commit0cedd345aa67cb49c95e704cab36e6d020cb1587 (patch)
tree9a8bdadaa6d3cf0e837cd51fd3d6adf005ce6ca2 /media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
parentAdded fix for new java system. Thank Caster and Tichoj for fix and Jan Callew... (diff)
downloadhistorical-0cedd345aa67cb49c95e704cab36e6d020cb1587.tar.gz
historical-0cedd345aa67cb49c95e704cab36e6d020cb1587.tar.bz2
historical-0cedd345aa67cb49c95e704cab36e6d020cb1587.zip
Fix freetype-2.2 build problems with freetypes recommended patch thanks to foser in bug 145642
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild')
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
index 6a6f902b987b..88a12abd67bf 100644
--- a/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild,v 1.3 2006/07/28 20:08:31 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild,v 1.4 2006/08/31 11:51:16 genstef Exp $
+
+inherit eutils
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
@@ -18,12 +20,18 @@ DEPEND="X? ( || ( x11-libs/libXt virtual/x11 ) )
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/sdl-ttf-2.0.8-noftinternals.patch
+}
+
src_compile() {
- econf $(use_with X x) || die
+ econf $(use_with X x) || die "econf failed"
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc CHANGES README
}