summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-09 22:06:30 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-09 22:06:30 +0000
commit10faee90a03eaab9a9d6c049dee0f61f1bc352f8 (patch)
tree7a23be07cfd930047481876d4714442cf69befe8 /media-libs/tunepimp/tunepimp-0.5.1.ebuild
parentStable on x86. Remove obsolete version. (diff)
downloadhistorical-10faee90a03eaab9a9d6c049dee0f61f1bc352f8.tar.gz
historical-10faee90a03eaab9a9d6c049dee0f61f1bc352f8.tar.bz2
historical-10faee90a03eaab9a9d6c049dee0f61f1bc352f8.zip
Version bump.
Package-Manager: portage-2.1.1
Diffstat (limited to 'media-libs/tunepimp/tunepimp-0.5.1.ebuild')
-rw-r--r--media-libs/tunepimp/tunepimp-0.5.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/tunepimp/tunepimp-0.5.1.ebuild b/media-libs/tunepimp/tunepimp-0.5.1.ebuild
new file mode 100644
index 000000000000..daf0b0002027
--- /dev/null
+++ b/media-libs/tunepimp/tunepimp-0.5.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.5.1.ebuild,v 1.1 2006/09/09 22:06:30 carlo Exp $
+
+inherit eutils distutils perl-app
+
+MY_P="lib${P}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="TunePimp is a library to create MusicBrainz enabled tagging applications."
+HOMEPAGE="http://www.musicbrainz.org/products/tunepimp"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+# Most use flags were void as not deterministic - needs a patch sooner or later.
+#IUSE="flac mp3 readline perl python vorbis"
+IUSE="python"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat
+ net-misc/curl
+ media-libs/flac
+ media-libs/libmad
+ >=media-libs/musicbrainz-2.1.0
+ media-libs/libofa
+ media-libs/libvorbis
+ !media-sound/trm
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ # broken script, install fails
+ sed -i -e "s: tta::" configure.in
+ libtoolize --copy --force
+ autoheader
+ automake --foreign --add-missing --copy --include-deps
+ aclocal
+ autoconf
+
+ econf || die "configure failed"
+ emake || die "emake failed"
+ # disabled as broken with Perl 5.8.8
+ #if use perl; then
+ # cd ${S}/perl/tunepimp-perl
+ # perl-app_src_compile || die "perl module failed to compile"
+ #fi
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+ if use python; then
+ cd ${S}/python
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/*
+ fi
+# if use perl; then
+# cd ${S}/perl/tunepimp-perl
+# perl-module_src_install || die "perl module failed to install"
+# insinto /usr/share/doc/${PF}/examples/
+# doins examples/*
+# fi
+}