summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-10 21:14:36 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-10 21:14:36 +0000
commit437ddb75f673f70054c382a4d09876b0507dae84 (patch)
treea9a2cc151cd255d3d3606902c5b2637b5d8308ab /media-libs/xvid/xvid-0.9.2-r1.ebuild
parentAdding compatible symblink. (diff)
downloadhistorical-437ddb75f673f70054c382a4d09876b0507dae84.tar.gz
historical-437ddb75f673f70054c382a4d09876b0507dae84.tar.bz2
historical-437ddb75f673f70054c382a4d09876b0507dae84.zip
Adding compatible symblink.
Diffstat (limited to 'media-libs/xvid/xvid-0.9.2-r1.ebuild')
-rw-r--r--media-libs/xvid/xvid-0.9.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/xvid/xvid-0.9.2-r1.ebuild b/media-libs/xvid/xvid-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..c347c0118b14
--- /dev/null
+++ b/media-libs/xvid/xvid-0.9.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-0.9.2-r1.ebuild,v 1.1 2003/08/10 21:14:26 mholzer Exp $
+
+MY_P=${PN}core-${PV}
+S="${WORKDIR}/${MY_P}/build/generic"
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution."
+SRC_URI="http://files.xvid.org/downloads/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.xvid.org/"
+
+DEPEND="virtual/glibc
+ x86? ( >=dev-lang/nasm-0.98.36 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+
+src_compile() {
+ [ -z "${CC}" ] && export CC="gcc"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/{include,lib}
+ einstall || die
+
+ cd ${S}/../../
+
+ dodoc authors.txt changelog.txt LICENSE README.txt todo.txt
+ dosym /usr/lib/libxvidcore.so.2.1 /usr/lib/libxvidcore.so
+
+ if [ "`use doc`" ]
+ then
+ dodoc CodingStyle doc/README doc/xvid-decoding.txt doc/xvid-encoder.txt
+
+ dodoc doc/xvid-api-ref.pdf
+ dohtml -r doc/xvid-api-ref
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ # Empty for this release ...
+ #insinto /usr/share/doc/${PF}/examples/ex1
+ #doins examples/ex1/*
+ fi
+}