summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-08 13:52:05 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-08 13:52:05 +0000
commit7012f72df0398de97a59eaa713c56e4ceaf48c1e (patch)
tree59cf993175ae8a5bad329e2df321be9d494d9165 /media-libs
parentMore qpkg updates, removed old versions (diff)
downloadhistorical-7012f72df0398de97a59eaa713c56e4ceaf48c1e.tar.gz
historical-7012f72df0398de97a59eaa713c56e4ceaf48c1e.tar.bz2
historical-7012f72df0398de97a59eaa713c56e4ceaf48c1e.zip
directfb support compilation enabled
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog9
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.9-r21
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.9-r2.ebuild91
3 files changed, 100 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 5119222ae4ff..fc9ae8ba7401 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.7 2002/05/26 22:22:34 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.8 2002/06/08 13:52:04 seemant Exp $
+
+*xine-lib-0.9.9-r2 (r87 Jun 2002)
+
+ 8 Jun 2002; Seemant Kulleen <seemant@gentoo.org> xine-lib-0.9.9-r2.ebuild
+ files/digest-xine-lib-0.9.9-r2 :
+
+ Fixes to make it compile against directfb.
*xine-lib-0.9.10 (26 May 2002)
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r2 b/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r2
new file mode 100644
index 000000000000..0020fb7cc1b1
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.9-r2
@@ -0,0 +1 @@
+MD5 fd628882e9140311868f28da929fbd75 xine-lib-0.9.9.tar.gz 1986745
diff --git a/media-libs/xine-lib/xine-lib-0.9.9-r2.ebuild b/media-libs/xine-lib/xine-lib-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..aec33eb13c28
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.9-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.9-r2.ebuild,v 1.1 2002/06/08 13:52:05 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+SRC_URI="http://xine.sourceforge.net/files/xine-lib-${PV}.tar.gz"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ oggvorbis? ( media-libs/libvorbis )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ for i in ${S} ${S}/src/video_out
+ do
+ cp ${i}/Makefile.in ${i}/Makefile.in.orig
+ sed 's:$(SDL_CFLAGS):$(DIRECTFB_CFLAGS) $(SDL_CFLAGS):' \
+ ${i}/Makefile.in.orig > ${i}/Makefile.in
+ done
+}
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd || myconf="${myconf} --disable-esd --disable-esdtest"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa --disable-alsatest"
+ use arts || myconf="${myconf} --disable-arts --disable-artstest"
+ # This breaks because with the test disabled, it defaults to "found" check with
+ # the next release until then let it autodetect. See bug #2377.
+ # use aalib || myconf="${myconf} --disable-aalib --disable-aalibtest"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest --disable-vorbis --disable-vorbistest"
+
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ # This is ``fixes'' compilation problems when em8300 libs installed
+ # The proper fix is to follow.
+ myconf="${myconf} --disable-dxr3 --disable-dxr3test"
+
+ use directfb \
+ && CPPFLAGS="${CPPFLAGS} -I/usr/include/directfb"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}