summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-02-09 16:22:39 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-02-09 16:22:39 +0000
commitb534e00de821d34dc04262ff340a5a204afd0900 (patch)
treead6a5067ca1adfea0c9b03ec259b39faa50a1535 /media-libs
parentAdded to ~hppa. Revert after talking with flameeyes. (diff)
downloadhistorical-b534e00de821d34dc04262ff340a5a204afd0900.tar.gz
historical-b534e00de821d34dc04262ff340a5a204afd0900.tar.bz2
historical-b534e00de821d34dc04262ff340a5a204afd0900.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog8
-rw-r--r--media-libs/gst-plugins-base/files/digest-gst-plugins-base-0.10.31
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.3.ebuild85
3 files changed, 93 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index e44b7528ab83..acfcd5b21fde 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.6 2006/01/22 06:55:30 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.7 2006/02/09 16:22:39 zaheerm Exp $
+
+*gst-plugins-base-0.10.3 (09 Feb 2006)
+
+ 09 Feb 2006; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +gst-plugins-base-0.10.3.ebuild:
+ version bump
22 Jan 2006; Doug Goldstein <cardoe@gentoo.org>
gst-plugins-base-0.10.2.ebuild:
diff --git a/media-libs/gst-plugins-base/files/digest-gst-plugins-base-0.10.3 b/media-libs/gst-plugins-base/files/digest-gst-plugins-base-0.10.3
new file mode 100644
index 000000000000..2bce2e985050
--- /dev/null
+++ b/media-libs/gst-plugins-base/files/digest-gst-plugins-base-0.10.3
@@ -0,0 +1 @@
+MD5 8fb69b7c5eb98f15c45c659cad3cb614 gst-plugins-base-0.10.3.tar.bz2 1082763
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.3.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.3.ebuild
new file mode 100644
index 000000000000..babeecc0dece
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.3.ebuild,v 1.1 2006/02/09 16:22:39 zaheerm Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=media-libs/gstreamer-0.10.3
+ >=dev-libs/liboil-0.3.2
+ || ( ( x11-libs/libXext
+ x11-libs/libSM )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9
+ || ( ( x11-proto/xproto
+ x11-proto/videoproto
+ x11-proto/xextproto )
+ virtual/x11 )"
+
+
+# we need x for the x overlay to get linked
+GST_PLUGINS_BUILD="x xshm"
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-base_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+
+}