summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:19:00 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:19:00 +0000
commite3e26cdf0bd6274ce9643b7e7e774bbca41163f6 (patch)
treecd2fb28875415e147003d442e234a8bbe0d91736 /media-libs
parentfont alignment fix #28054 (diff)
downloadhistorical-e3e26cdf0bd6274ce9643b7e7e774bbca41163f6.tar.gz
historical-e3e26cdf0bd6274ce9643b7e7e774bbca41163f6.tar.bz2
historical-e3e26cdf0bd6274ce9643b7e7e774bbca41163f6.zip
fix head -1 script #28316
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/libsdl-1.2.5-r1.ebuild4
-rw-r--r--media-libs/libsdl/libsdl-1.2.5-r2.ebuild3
-rw-r--r--media-libs/libsdl/libsdl-1.2.6.ebuild4
3 files changed, 8 insertions, 3 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.5-r1.ebuild b/media-libs/libsdl/libsdl-1.2.5-r1.ebuild
index 825c5706ae68..74204bc90efc 100644
--- a/media-libs/libsdl/libsdl-1.2.5-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r1.ebuild,v 1.9 2003/09/06 23:59:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r1.ebuild,v 1.10 2003/09/10 04:19:00 vapier Exp $
IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
@@ -35,6 +35,8 @@ src_unpack() {
cp SDL_DirectFB_video.c SDL_DirectFB_video.c.orig
sed -e "s:DICAPS_ALL, ::" SDL_DirectFB_video.c.orig \
> SDL_DirectFB_video.c
+ cd ${S}
+ sed -i 's:head -1:head -n 1:' configure
}
src_compile() {
diff --git a/media-libs/libsdl/libsdl-1.2.5-r2.ebuild b/media-libs/libsdl/libsdl-1.2.5-r2.ebuild
index 26fefe45c3d7..ba2e5416015b 100644
--- a/media-libs/libsdl/libsdl-1.2.5-r2.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r2.ebuild,v 1.7 2003/07/29 21:17:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r2.ebuild,v 1.8 2003/09/10 04:19:00 vapier Exp $
IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
@@ -41,6 +41,7 @@ src_unpack() {
# resolution in XFree86-4.3 instead of the worst one.
cd ${S}
use X && epatch ${FILESDIR}/${P}-xfree-4.3.patch.bz2
+ sed -i 's:head -1:head -n 1:' configure
}
src_compile() {
diff --git a/media-libs/libsdl/libsdl-1.2.6.ebuild b/media-libs/libsdl/libsdl-1.2.6.ebuild
index db4cf1df72ba..68216d80ebbb 100644
--- a/media-libs/libsdl/libsdl-1.2.6.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6.ebuild,v 1.1 2003/09/09 02:00:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6.ebuild,v 1.2 2003/09/10 04:19:00 vapier Exp $
DESCRIPTION="Simple Direct Media Layer"
HOMEPAGE="http://www.libsdl.org/"
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/SDL-${PV}
src_compile() {
+ sed -i 's:head -1:head -n 1:' configure
+
local myconf
if use oss || use alsa || use esd || use arts || use nas ; then
myconf="${myconf} --enable-audio"