summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-01-16 18:55:16 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-01-16 18:55:16 +0000
commitdd737779663c0d0b04baefb404c56419d2ee1906 (patch)
tree32d376a828df40037b039bddcdf31f34ac9b30d4 /media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild
parentNew upstream version; Alter the Emacs 22 versus Emacs 21 patch for easy-menu-... (diff)
downloadhistorical-dd737779663c0d0b04baefb404c56419d2ee1906.tar.gz
historical-dd737779663c0d0b04baefb404c56419d2ee1906.tar.bz2
historical-dd737779663c0d0b04baefb404c56419d2ee1906.zip
Added a patch to fix segfault upon exit thanks to Thomas Cort <tcort@cs.ubishops.ca>. Fixes bug #74831.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild')
-rw-r--r--media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild b/media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild
new file mode 100644
index 000000000000..dbe0353b1e27
--- /dev/null
+++ b/media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/eq-xmms/eq-xmms-0.6-r5.ebuild,v 1.1 2006/01/16 18:55:16 metalgod Exp $
+
+IUSE="sse-filters"
+
+inherit eutils autotools
+
+DESCRIPTION="EQU is a realtime graphical equalizer effect plugin that will equalize almost everything that you play through XMMS, not just the MP3s"
+HOMEPAGE="http://equ.sourceforge.net/"
+SRC_URI="mirror://sourceforge/equ/${P}.tar.gz
+http://dev.gentoo.org/~voxus/equ/eq-xmms-0.6-cvs-20051113.patch.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+
+RDEPEND="media-sound/xmms"
+DEPEND="${RDEPEND}
+ !x86? ( >=sys-devel/automake-1.7 )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-shade_fix.patch
+ epatch ${FILESDIR}/${P}-mono_fix.patch
+ epatch ${FILESDIR}/${P}-exit_fix.patch
+
+ if ! use x86 || use sse-filters; then
+ cd ${S}
+
+ if use sse-filters; then
+ epatch ${FILESDIR}/${P}-sse_filters.patch.bz2
+ epatch ${FILESDIR}/${P}-sse_round_trickfilters.patch
+ epatch ${DISTDIR}/${P}-cvs-20051113.patch.bz2
+ fi
+
+ use x86 || epatch ${FILESDIR}/${P}-nonx86.patch
+
+ export WANT_AUTOMAKE="1.7"
+ export WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ use sse-filters && \
+ sed -e "s:@CFLAGS@:@CFLAGS@ -DSSE_FILTERS:" -i ${S}/src/Makefile.in
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" libdir=`xmms-config --effect-plugin-dir` install || die
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.BSD SKINS TODO
+}