summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-28 16:40:45 +0000
committerMax Kalika <max@gentoo.org>2003-10-28 16:40:45 +0000
commitb6e3e83e63e88d6281deaffb4f5a4dec095ea4f3 (patch)
treed952a7cce4971e41abb2a813ef468b8e87481685 /media-plugins/mythnews
parentExtend CPU detection. (diff)
downloadhistorical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.tar.gz
historical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.tar.bz2
historical-b6e3e83e63e88d6281deaffb4f5a4dec095ea4f3.zip
Extend CPU detection.
Diffstat (limited to 'media-plugins/mythnews')
-rw-r--r--media-plugins/mythnews/ChangeLog5
-rw-r--r--media-plugins/mythnews/Manifest4
-rw-r--r--media-plugins/mythnews/mythnews-0.12.ebuild4
3 files changed, 8 insertions, 5 deletions
diff --git a/media-plugins/mythnews/ChangeLog b/media-plugins/mythnews/ChangeLog
index 16144fc9c353..1079f68b54de 100644
--- a/media-plugins/mythnews/ChangeLog
+++ b/media-plugins/mythnews/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-plugins/mythnews
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/ChangeLog,v 1.1 2003/10/20 03:39:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/ChangeLog,v 1.2 2003/10/28 16:35:34 max Exp $
+
+ 28 Oct 2003; Max Kalika <max@gentoo.org> mythnews-0.12.ebuild:
+ Extend CPU detection.
*mythnews-0.12 (19 Oct 2003)
diff --git a/media-plugins/mythnews/Manifest b/media-plugins/mythnews/Manifest
index 322cff1528a4..9008913f270e 100644
--- a/media-plugins/mythnews/Manifest
+++ b/media-plugins/mythnews/Manifest
@@ -1,4 +1,4 @@
-MD5 340dc74f34f21f967ff236d24472375c mythnews-0.12.ebuild 973
-MD5 2621c2bba413e541617acbac66c2cbda ChangeLog 351
+MD5 4b3a6e51e22a4694afce8a3094f4ad4d mythnews-0.12.ebuild 990
+MD5 6dedd0011fc733757f1d29c5b1725379 ChangeLog 441
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 4173f85528c0fed69c65345d080ddc6b files/digest-mythnews-0.12 65
diff --git a/media-plugins/mythnews/mythnews-0.12.ebuild b/media-plugins/mythnews/mythnews-0.12.ebuild
index 07217d21c3c2..c793e884503b 100644
--- a/media-plugins/mythnews/mythnews-0.12.ebuild
+++ b/media-plugins/mythnews/mythnews-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/mythnews-0.12.ebuild,v 1.1 2003/10/20 03:39:32 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/mythnews-0.12.ebuild,v 1.2 2003/10/28 16:35:34 max Exp $
inherit flag-o-matic
@@ -24,7 +24,7 @@ src_unpack() {
}
src_compile() {
- local cpu="`get-flag march`"
+ local cpu="`get-flag march || get-flag mcpu`"
if [ ! -z "${cpu}" ] ; then
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi