summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
commit0b9ff7f26ebe9368b057444d355299f76f64d491 (patch)
tree8297ad0f5fd3430306366d5d0f17dde10155ea99 /media-plugins/mythvideo
parentManifest fix. (diff)
downloadhistorical-0b9ff7f26ebe9368b057444d355299f76f64d491.tar.gz
historical-0b9ff7f26ebe9368b057444d355299f76f64d491.tar.bz2
historical-0b9ff7f26ebe9368b057444d355299f76f64d491.zip
Bump version to 0.11.
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog8
-rw-r--r--media-plugins/mythvideo/Manifest4
-rw-r--r--media-plugins/mythvideo/files/digest-mythvideo-0.111
-rw-r--r--media-plugins/mythvideo/mythvideo-0.11.ebuild63
4 files changed, 74 insertions, 2 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index 6753a0de6f14..482d587e12d6 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.2 2003/08/08 05:13:41 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.3 2003/08/18 18:05:48 max Exp $
+
+*mythvideo-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythvideo-0.11.ebuild:
+ Bump version to 0.11. Add mplayer or xine-ui to RDEPEND. Change make install
+ to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythvideo-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythvideo/Manifest b/media-plugins/mythvideo/Manifest
index dfcf699ae162..637412931513 100644
--- a/media-plugins/mythvideo/Manifest
+++ b/media-plugins/mythvideo/Manifest
@@ -1,3 +1,5 @@
MD5 c941afde9a6ccac5e694cdc43db6bf52 mythvideo-0.10.ebuild 1736
-MD5 0ad2b67f0b510fcd5a979c77a8fd2e66 ChangeLog 1500
+MD5 92d55406d6084728270809054a483339 mythvideo-0.11.ebuild 1751
+MD5 15091b5845360d331b617a2faeaab467 ChangeLog 1692
MD5 bdd77fadda8f0eb40802ceb421042c18 files/digest-mythvideo-0.10 67
+MD5 1c1055ed7527e3c6e5c556e1f79456bc files/digest-mythvideo-0.11 67
diff --git a/media-plugins/mythvideo/files/digest-mythvideo-0.11 b/media-plugins/mythvideo/files/digest-mythvideo-0.11
new file mode 100644
index 000000000000..2022f315e773
--- /dev/null
+++ b/media-plugins/mythvideo/files/digest-mythvideo-0.11
@@ -0,0 +1 @@
+MD5 7825a89f31df0a4cd73541f915c409fd mythvideo-0.11.tar.bz2 198184
diff --git a/media-plugins/mythvideo/mythvideo-0.11.ebuild b/media-plugins/mythvideo/mythvideo-0.11.ebuild
new file mode 100644
index 000000000000..801db6fdd81c
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.11.ebuild,v 1.1 2003/08/18 18:05:48 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Video player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( media-video/mplayer media-video/xine-ui )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins videodb/*.sql
+
+ dodoc COPYING README
+ newdoc videodb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythVideo,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}