summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:57:01 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:57:01 +0000
commit0ee0fd6620d9a0d9ccf47fc9842a2979efc5dbc3 (patch)
tree7f176d73d8e6d459d2608009fa28b96457203a4c /media-plugins/mythweather
parentinitial check-in (diff)
downloadhistorical-0ee0fd6620d9a0d9ccf47fc9842a2979efc5dbc3.tar.gz
historical-0ee0fd6620d9a0d9ccf47fc9842a2979efc5dbc3.tar.bz2
historical-0ee0fd6620d9a0d9ccf47fc9842a2979efc5dbc3.zip
initial check-in
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog29
-rw-r--r--media-plugins/mythweather/Manifest2
-rw-r--r--media-plugins/mythweather/mythweather-0.10.ebuild48
3 files changed, 79 insertions, 0 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
new file mode 100644
index 000000000000..801df88a4989
--- /dev/null
+++ b/media-plugins/mythweather/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for media-plugins/mythweather
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.1 2003/07/08 23:56:30 johnm Exp $
+
+ 03 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.8.ebuild:
+ Set KEYWORDS to ~x86.
+
+*mythweather-0.10 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.10.ebuild:
+ Bump version to 0.10.
+
+ 22 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.9.ebuild:
+ Cleanup and consistancy: depend on sed-4, die if sed fails. Drop unused
+ myconf setting. Fix erroneous double cpu check.
+
+ 18 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.9.ebuild:
+ Change depend to media-tv/mythtv.
+
+*mythweather-0.9 (09 Jun 2003)
+
+ 09 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.9.ebuild:
+ Bump to 0.9. Make all sed operations inline. accid.dat no longer comes
+ comressed so remove the gunzip line.
+
+*mythweather-0.8 (27 Mar 2003)
+
+ 26 Mar 2003; Max Kalika <max@lsit.ucsb.edu> mythweather-0.9.ebuild:
+ Initial import.
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
new file mode 100644
index 000000000000..ac63d0bd411f
--- /dev/null
+++ b/media-plugins/mythweather/Manifest
@@ -0,0 +1,2 @@
+MD5 7f7e76dfa5f2793a69d33fb7f3e02536 mythweather-0.10.ebuild 987
+MD5 acc9b6eaab5b47d947cd0699d6ce9fe8 ChangeLog 1095
diff --git a/media-plugins/mythweather/mythweather-0.10.ebuild b/media-plugins/mythweather/mythweather-0.10.ebuild
new file mode 100644
index 000000000000..4d0b18e261f6
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.10.ebuild,v 1.1 2003/07/08 23:56:30 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ dodoc AUTHORS COPYING README
+
+}