summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-10-12 22:23:08 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-10-12 22:23:08 +0000
commit05628fb1b8dba1073cd2b4a6db79f4e8873d6d06 (patch)
treec31b6098a54e0cb2b9968953c98c91be3de88aad /media-plugins
parentversion bump to fix bugs in 3.5.5 as per bug #150989 (diff)
downloadhistorical-05628fb1b8dba1073cd2b4a6db79f4e8873d6d06.tar.gz
historical-05628fb1b8dba1073cd2b4a6db79f4e8873d6d06.tar.bz2
historical-05628fb1b8dba1073cd2b4a6db79f4e8873d6d06.zip
New upstream release. Contains Apple Lossless Audio Codec (ALAC) support together with the usual sprinkling of bugfixes & stability improvements.
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog9
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.2.1.ebuild97
-rw-r--r--media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.13
3 files changed, 108 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 97bbe16317a0..3f0162c3fef9 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.3 2006/09/29 08:23:32 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.4 2006/10/12 22:23:08 chainsaw Exp $
+
+*audacious-plugins-1.2.1 (12 Oct 2006)
+
+ 12 Oct 2006; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-plugins-1.2.1.ebuild:
+ New upstream release. Contains Apple Lossless Audio Codec (ALAC) support
+ together with the usual sprinkling of bugfixes & stability improvements.
29 Sep 2006; Tony Vroon <chainsaw@gentoo.org>
audacious-plugins-1.2.0-r1.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.2.1.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.2.1.ebuild
new file mode 100644
index 000000000000..be0120813447
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.2.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.2.1.ebuild,v 1.1 2006/10/12 22:23:08 chainsaw Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aac alsa arts esd flac jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma pulseaudio"
+
+RDEPEND="app-arch/unzip
+ dev-libs/libxml2
+ net-misc/curl
+ media-libs/musicbrainz
+ >=media-sound/audacious-1.2.0_rc1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ media-libs/taglib
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable mmx simd) \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ $(use_enable pulseaudio pulse) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.1 b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.1
new file mode 100644
index 000000000000..354f4060730b
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.1
@@ -0,0 +1,3 @@
+MD5 d3cd6867a321270151fb4f2a53e5d6a0 audacious-plugins-1.2.1.tgz 2104064
+RMD160 18be48dc1fa412a45845d307b7322fa53982ca0b audacious-plugins-1.2.1.tgz 2104064
+SHA256 b49c88dfda3124aab7924098ff8632df8a783cb08887835bffe20d3bddc3dda7 audacious-plugins-1.2.1.tgz 2104064