summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Romans <killsoft@gentoo.org>2005-03-31 01:24:44 +0000
committerRob Romans <killsoft@gentoo.org>2005-03-31 01:24:44 +0000
commit7d3474d69f4d224d44afef155d99cb4d4e1c0d6c (patch)
tree5235d8d702addeabd541d987b7214fa381a6daec /media-radio/tlf/tlf-0.9.23.ebuild
parentRemoved unecessary einfo. bug# 87304 (diff)
downloadhistorical-7d3474d69f4d224d44afef155d99cb4d4e1c0d6c.tar.gz
historical-7d3474d69f4d224d44afef155d99cb4d4e1c0d6c.tar.bz2
historical-7d3474d69f4d224d44afef155d99cb4d4e1c0d6c.zip
new ebuild
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-radio/tlf/tlf-0.9.23.ebuild')
-rw-r--r--media-radio/tlf/tlf-0.9.23.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-0.9.23.ebuild b/media-radio/tlf/tlf-0.9.23.ebuild
new file mode 100644
index 000000000000..099cce16ec17
--- /dev/null
+++ b/media-radio/tlf/tlf-0.9.23.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tlf/tlf-0.9.23.ebuild,v 1.1 2005/03/31 01:24:44 killsoft Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+RDEPEND="virtual/libc
+ sys-libs/ncurses
+ media-libs/hamlib"
+
+DEPEND="sys-apps/gawk"
+
+src_compile() {
+ append-flags -L/usr/lib/hamlib
+ econf --enable-hamlib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+}