summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-04-15 14:03:32 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-04-15 14:03:32 +0000
commitb16dc05d2ad7eee8c84a46f64e227a090ce7373e (patch)
treeda568871ccf6bd9476fdda47882cd2f09707677c /media-radio/tucnak2/tucnak2-2.48.ebuild
parentFix build with gcc 4.7, bug 411803 by Andrew John Hughes. (diff)
downloadhistorical-b16dc05d2ad7eee8c84a46f64e227a090ce7373e.tar.gz
historical-b16dc05d2ad7eee8c84a46f64e227a090ce7373e.tar.bz2
historical-b16dc05d2ad7eee8c84a46f64e227a090ce7373e.zip
Version bump. Remove old
Package-Manager: portage-2.1.10.56/cvs/Linux x86_64
Diffstat (limited to 'media-radio/tucnak2/tucnak2-2.48.ebuild')
-rw-r--r--media-radio/tucnak2/tucnak2-2.48.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-radio/tucnak2/tucnak2-2.48.ebuild b/media-radio/tucnak2/tucnak2-2.48.ebuild
new file mode 100644
index 000000000000..16a733de73f0
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.48.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.48.ebuild,v 1.1 2012/04/15 14:03:32 tomjbe Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw ftdi gpm hamlib suid"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-doc.diff" \
+ "${FILESDIR}/${PN}-2.42-appname.diff"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3) --with-sdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman debian.unofficial/tucnak2.1
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}