summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-19 23:34:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-19 23:34:40 +0000
commitfa278152ef02d721a3334ab71377ff911edd1db7 (patch)
treea261cc88ef54617e8e24af04a3d34cb14b0e706f /media-sound/alsa-driver
parentVersion bump. This version will replace all the old release candidates. (diff)
downloadhistorical-fa278152ef02d721a3334ab71377ff911edd1db7.tar.gz
historical-fa278152ef02d721a3334ab71377ff911edd1db7.tar.bz2
historical-fa278152ef02d721a3334ab71377ff911edd1db7.zip
Drop release candidate versions.
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc3.ebuild163
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild167
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc5.ebuild169
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.11_rc5-powermac.patch11
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc33
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc43
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc53
8 files changed, 7 insertions, 520 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index abcfc60645e3..7df92dc3c17f 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.205 2006/04/19 23:27:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.206 2006/04/19 23:34:30 flameeyes Exp $
+
+ 19 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alsa-driver-1.0.11_rc5-powermac.patch,
+ -alsa-driver-1.0.11_rc3.ebuild, -alsa-driver-1.0.11_rc4.ebuild,
+ -alsa-driver-1.0.11_rc5.ebuild:
+ Drop release candidate versions.
*alsa-driver-1.0.11 (19 Apr 2006)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc3.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc3.ebuild
deleted file mode 100644
index d2de9ff9a360..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc3.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc3.ebuild,v 1.2 2006/02/02 19:16:53 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc debug"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- export CBUILD=${CBUILD-${CHOST}}
- export CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- $(use_with debug debug full) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild
deleted file mode 100644
index 410ca843647b..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild,v 1.3 2006/03/25 12:08:43 blubb Exp $
-
-inherit linux-mod flag-o-matic eutils multilib
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc debug"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- export CBUILD=${CBUILD-${CHOST}}
- export CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- local myABI=${ABI:-${DEFAULT_ABI}}
-
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- $(use_with debug debug full) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- ABI=${KERNEL_ABI}
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
- ABI=${myABI}
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc5.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc5.ebuild
deleted file mode 100644
index c001fd054329..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc5.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc5.ebuild,v 1.2 2006/04/18 20:44:26 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils multilib
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc debug"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- export CBUILD=${CBUILD-${CHOST}}
- export CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
-
- epatch "${FILESDIR}/${P}-powermac.patch"
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- local myABI=${ABI:-${DEFAULT_ABI}}
-
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- $(use_with debug debug full) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- ABI=${KERNEL_ABI}
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
- ABI=${myABI}
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc5-powermac.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc5-powermac.patch
deleted file mode 100644
index 5dc15746fb8a..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc5-powermac.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- alsa-driver-1.0.11rc5/ppc/../alsa-kernel/ppc/pmac.c_orig 2006-04-06 15:50:03.000000000 +0200
-+++ alsa-driver-1.0.11rc5/ppc/../alsa-kernel/ppc/pmac.c 2006-04-18 21:58:29.000000000 +0200
-@@ -869,7 +869,7 @@
-
- u32 layout_id = 0;
-
-- if (!machine_is(powermac))
-+ if (_machine != _MACH_Pmac)
- return -ENODEV;
-
- chip->subframe = 0;
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc3 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc3
deleted file mode 100644
index b627d4f150d6..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 83b25ec7a0aa6135e21730e797c81a7a alsa-driver-1.0.11rc3.tar.bz2 2315294
-RMD160 a8ecce212a15de4ce53783ac04bb5bf9125d070e alsa-driver-1.0.11rc3.tar.bz2 2315294
-SHA256 c85cd217ebdb1a80651ca1a352228f92ec4073cf0e8d4cef3dcc3cad58580f1e alsa-driver-1.0.11rc3.tar.bz2 2315294
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc4 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc4
deleted file mode 100644
index ab987f0cfdb3..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8e5794026082a964b09b46f9d881e6ec alsa-driver-1.0.11rc4.tar.bz2 2339406
-RMD160 586f88e6fa961047c41d2584ad3152965af1115d alsa-driver-1.0.11rc4.tar.bz2 2339406
-SHA256 5c1558e425107f2a360a10b87b39ba0576ba33a3da42c8af4b7f381f0eacb706 alsa-driver-1.0.11rc4.tar.bz2 2339406
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc5 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc5
deleted file mode 100644
index e0ed610a2b47..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2b36ba8a68b4a5cf593893683547cfb7 alsa-driver-1.0.11rc5.tar.bz2 2341730
-RMD160 9972e9c38db43ab8f61b3f22575ce49f59096bb2 alsa-driver-1.0.11rc5.tar.bz2 2341730
-SHA256 6270e9b565f006e6cf2fab554ff876dfbe9033daddcc89de9d7cbc6f5809f7be alsa-driver-1.0.11rc5.tar.bz2 2341730