summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 23:49:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 23:49:11 +0000
commitf600009f93d26470ab893bb3ed6c737a778ad3b5 (patch)
tree344da5a4f89d170993ca325287574f854fba092a /media-sound/alsa-utils/files
parentStable on SPARC wrt security bug #162364. (diff)
downloadhistorical-f600009f93d26470ab893bb3ed6c737a778ad3b5.tar.gz
historical-f600009f93d26470ab893bb3ed6c737a778ad3b5.tar.bz2
historical-f600009f93d26470ab893bb3ed6c737a778ad3b5.zip
Add patch to allow disabling sequencer-related utilities, so that the package can be built without midi support enabled in alsa-lib.
Package-Manager: portage-2.1.2
Diffstat (limited to 'media-sound/alsa-utils/files')
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.14_rc2-seq.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.14_rc2-seq.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.14_rc2-seq.patch
new file mode 100644
index 000000000000..da26315363f7
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.14_rc2-seq.patch
@@ -0,0 +1,41 @@
+Index: alsa-utils-1.0.14rc2/configure.in
+===================================================================
+--- alsa-utils-1.0.14rc2.orig/configure.in
++++ alsa-utils-1.0.14rc2/configure.in
+@@ -82,6 +82,18 @@ AC_ARG_WITH(testsound,
+ TESTSOUND="$dir/test.wav")
+ AC_SUBST(TESTSOUND)
+
++AC_ARG_ENABLE([sequencer],
++ [AC_HELP_STRING([--disable-sequencer], [Disable sequencer utilities (aconnect, aplaymidi, aseqdump, aseqnet)])] )
++
++if test "x$enable_sequencer" != "xno"; then
++ AC_CHECK_LIB([asound], [snd_seq_open], [has_seq=yes], [has_seq=no])
++fi
++if test "x$enable_sequencer" = "xyes" && test "x$has_seq" = "xno"; then
++ AC_MSG_FAILURE([cannot find snd_seq_open. ALSA was built without sequencer support])
++fi
++
++AM_CONDITIONAL([BUILD_SEQ], [test "x$has_seq" = "xyes"])
++
+ AM_CONFIG_HEADER(include/aconfig.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+Index: alsa-utils-1.0.14rc2/Makefile.am
+===================================================================
+--- alsa-utils-1.0.14rc2.orig/Makefile.am
++++ alsa-utils-1.0.14rc2/Makefile.am
+@@ -4,7 +4,12 @@ ALSAMIXER_DIR=alsamixer
+ else
+ ALSAMIXER_DIR=
+ endif
+-SUBDIRS= include alsactl alsaconf $(ALSAMIXER_DIR) amidi amixer aplay iecset seq speaker-test utils m4 po
++
++if BUILD_SEQ
++SEQ_DIR=seq
++endif
++
++SUBDIRS= include alsactl alsaconf $(ALSAMIXER_DIR) amidi amixer aplay iecset $(SEQ_DIR) speaker-test utils m4 po
+ EXTRA_DIST= config.rpath mkinstalldirs config.rpath mkinstalldirs ChangeLog INSTALL TODO README configure hgcompile depcomp
+ AUTOMAKE_OPTIONS=foreign
+ ACLOCAL_AMFLAGS = -I m4