summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-11-21 20:01:37 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-11-21 20:01:37 +0000
commit5eef692bdb229d98aea1334185cec5e54e454326 (patch)
tree03c55a0449464a765c90582752a26ed0210966af /media-sound/ams/ams-1.8.7.ebuild
parentNew version. Changes include error highlighting for EXTRA_ECONF and cat abuse... (diff)
downloadhistorical-5eef692bdb229d98aea1334185cec5e54e454326.tar.gz
historical-5eef692bdb229d98aea1334185cec5e54e454326.tar.bz2
historical-5eef692bdb229d98aea1334185cec5e54e454326.zip
Version bump to 1.8.7.
Diffstat (limited to 'media-sound/ams/ams-1.8.7.ebuild')
-rw-r--r--media-sound/ams/ams-1.8.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/ams/ams-1.8.7.ebuild b/media-sound/ams/ams-1.8.7.ebuild
new file mode 100644
index 000000000000..5e0a3ff4aa6c
--- /dev/null
+++ b/media-sound/ams/ams-1.8.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ams/ams-1.8.7.ebuild,v 1.1 2004/11/21 20:01:37 fvdpol Exp $
+
+DESCRIPTION="Alsa Modular Software Synthesizer"
+HOMEPAGE="http://alsamodular.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=media-libs/alsa-lib-0.9
+ media-sound/jack-audio-connection-kit
+ >=x11-libs/qt-3.0.0
+ =dev-libs/fftw-2*
+ media-libs/ladspa-sdk
+ media-libs/libclalsadrv"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+SRC_URI="mirror://sourceforge/alsamodular/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ sed -i "s%QT_BASE_DIR=/usr/lib/qt3%QT_BASE_DIR=${QTDIR}%" Makefile || die "Makefile update failed."
+}
+
+src_compile() {
+ make || die "Make failed."
+}
+
+src_install() {
+ dobin ams
+
+ dodoc README INSTALL THANKS LICENSE
+
+ docinto examples
+ dodoc *.ams
+}