summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-12 18:40:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-12 18:40:00 +0000
commita3a5f39f3f68dc0d1584a06cd1a132561f49d647 (patch)
treee321e187668576102132ec5e77a38a091eef8e6b /media-sound/amsynth/amsynth-1.2.3.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-a3a5f39f3f68dc0d1584a06cd1a132561f49d647.tar.gz
historical-a3a5f39f3f68dc0d1584a06cd1a132561f49d647.tar.bz2
historical-a3a5f39f3f68dc0d1584a06cd1a132561f49d647.zip
version bump, bug #320421
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-sound/amsynth/amsynth-1.2.3.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.2.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.2.3.ebuild b/media-sound/amsynth/amsynth-1.2.3.ebuild
new file mode 100644
index 000000000000..3734e2a5f940
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.3.ebuild,v 1.1 2010/06/12 18:40:00 aballier Exp $
+
+EAPI=2
+MY_P=${P/ams/amS}
+
+DESCRIPTION="Virtual analogue synthesizer."
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa debug jack oss sndfile"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4
+ sndfile? ( >=media-libs/libsndfile-1 )
+ alsa? ( media-libs/alsa-lib
+ media-sound/alsa-utils )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with sndfile) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog
+ elog "amSynth has been installed normally. If you would like to use"
+ elog "the virtual keyboard option, then do:"
+ elog "# emerge vkeybd"
+ elog "and make sure you emerged amSynth with alsa support (USE=alsa)"
+ elog
+}