summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-08-02 22:07:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-08-02 22:07:33 +0000
commitbb34bee5bbe131e97ac6c99ed77e4b56a6234b16 (patch)
treee586a2f4d7c14c3da1dffe01fd515348c0583177 /media-sound/audiocompress/audiocompress-1.5.1.ebuild
parentcheck if is_koutput, bug #59159 (diff)
downloadhistorical-bb34bee5bbe131e97ac6c99ed77e4b56a6234b16.tar.gz
historical-bb34bee5bbe131e97ac6c99ed77e4b56a6234b16.tar.bz2
historical-bb34bee5bbe131e97ac6c99ed77e4b56a6234b16.zip
Version bump and -fPIC fixes. Closes bug #56026. Added -amd64.
Diffstat (limited to 'media-sound/audiocompress/audiocompress-1.5.1.ebuild')
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/audiocompress/audiocompress-1.5.1.ebuild b/media-sound/audiocompress/audiocompress-1.5.1.ebuild
new file mode 100644
index 000000000000..24154955841b
--- /dev/null
+++ b/media-sound/audiocompress/audiocompress-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.1.ebuild,v 1.1 2004/08/02 22:07:33 eradicator Exp $
+
+IUSE="xmms"
+
+inherit eutils
+
+MY_P="AudioCompress-${PV}"
+
+DESCRIPTION="AudioCompress is (essentially) a very gentle, 1-band dynamic range compressor intended to keep audio output at a consistent volume without introducing any audible artifacts."
+HOMEPAGE="http://trikuare.cx/code/AudioCompress.html"
+SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-amd64: 1.5.1 - Floating point exception when using xmms plugin
+KEYWORDS="~x86 -amd64"
+
+DEPEND="xmms? ( media-sound/xmms )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ make clean
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ if use xmms; then
+ emake || die
+ else
+ emake AudioCompress || die
+ fi
+}
+
+src_install() {
+ dobin AudioCompress || die
+ if use xmms; then
+ exeinto "$(xmms-config --effect-plugin-dir)" || die
+ doexe libcompress.so || die
+ fi
+ dodoc COPYING ChangeLog README TODO
+}