summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-10-18 22:37:56 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-10-18 22:37:56 +0000
commit71b613d173e8632c1620ae68641a350223f4e6b1 (patch)
tree94126ecfad02aa742f7dbb3f0694305cae1552d7 /media-sound/brutefir
parentInitial commit. Closes bug #109195 (diff)
downloadhistorical-71b613d173e8632c1620ae68641a350223f4e6b1.tar.gz
historical-71b613d173e8632c1620ae68641a350223f4e6b1.tar.bz2
historical-71b613d173e8632c1620ae68641a350223f4e6b1.zip
Version bump, closes bug #108906.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'media-sound/brutefir')
-rw-r--r--media-sound/brutefir/ChangeLog7
-rw-r--r--media-sound/brutefir/Manifest12
-rw-r--r--media-sound/brutefir/brutefir-1.0f.ebuild49
-rw-r--r--media-sound/brutefir/files/digest-brutefir-1.0f1
4 files changed, 63 insertions, 6 deletions
diff --git a/media-sound/brutefir/ChangeLog b/media-sound/brutefir/ChangeLog
index 500d0ccb212f..4d77d7b69fbd 100644
--- a/media-sound/brutefir/ChangeLog
+++ b/media-sound/brutefir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/brutefir
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/ChangeLog,v 1.7 2005/05/04 12:00:51 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/ChangeLog,v 1.8 2005/10/18 22:37:56 chainsaw Exp $
+
+*brutefir-1.0f (18 Oct 2005)
+
+ 18 Oct 2005; Tony Vroon <chainsaw@gentoo.org> +brutefir-1.0f.ebuild:
+ Version bump, closes bug #108906.
04 May 2005; David Holm <dholm@gentoo.org> brutefir-1.0c.ebuild:
Readded to ~ppc. Please don't remove it without filing a proper bugreport.
diff --git a/media-sound/brutefir/Manifest b/media-sound/brutefir/Manifest
index 7bfbf2b06c80..54e68bfe4425 100644
--- a/media-sound/brutefir/Manifest
+++ b/media-sound/brutefir/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 15f856f76d6fdf23b26440ca20c0ee3b ChangeLog 1078
+MD5 3884dd6c510ff66ae3aaa3a4081329cd ChangeLog 1219
MD5 c43ff38601053da1c3c6b7ee55c36be3 brutefir-1.0a.ebuild 1375
MD5 6436e194d5f16699d8e192a981c3664f brutefir-1.0c.ebuild 1440
+MD5 5fb30fa19c4e9cab5fb9106ddae5f903 brutefir-1.0f.ebuild 1440
MD5 e53cb835af1469d768807b0fd8ba01b5 files/digest-brutefir-1.0a 65
MD5 f3fe2cc506000749fab46ac8f60f5a77 files/digest-brutefir-1.0c 65
+MD5 61cb56ec32c0be03de77091426320138 files/digest-brutefir-1.0f 65
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC0CHVI1lqEGTUzyQRAkayAJ46AxPyJWO6k/9hSe6eDvOwc+UucACgg7YC
-zNrDWuLDZLgN9AQczCxQHgA=
-=L5Ar
+iD8DBQFDVXtep5vW4rUFj5oRAkUkAJ9yubyR9rfAWsCPPk8cCQdRvokiFgCfczzg
+snmXZ9Ju+tX85eENnAyKNiY=
+=ER23
-----END PGP SIGNATURE-----
diff --git a/media-sound/brutefir/brutefir-1.0f.ebuild b/media-sound/brutefir/brutefir-1.0f.ebuild
new file mode 100644
index 000000000000..277afa389037
--- /dev/null
+++ b/media-sound/brutefir/brutefir-1.0f.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/brutefir-1.0f.ebuild,v 1.1 2005/10/18 22:37:56 chainsaw Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="BruteFIR is a software convolution engine, a program for applying long FIR filters to multi-channel digital audio, either offline or in realtime."
+HOMEPAGE="http://www.ludd.luth.se/~torger/brutefir.html"
+SRC_URI="http://www.ludd.luth.se/~torger/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=media-libs/alsa-lib-0.9.1
+ media-sound/jack-audio-connection-kit
+ >=sci-libs/fftw-3.0.0"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/lib/brutefir
+
+ einstall DESTDIR=${D} \
+ INSTALL_PREFIX=${D}/usr || die "make install failed"
+
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+
+ dodoc CHANGES README LICENSE
+
+ insinto usr/share/brutefir
+ doins xtc_config directpath.txt crosspath.txt massive_config bench1_config bench2_config bench3_config bench4_config bench5_config
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Brutefir is a complicated piece of software. Please"
+ einfo "read the documentation first! You can find"
+ einfo "documentation here: http://www.ludd.luth.se/~torger/brutefir.html"
+ einfo "Example config files are in /usr/share/brutefir"
+ einfo
+}
diff --git a/media-sound/brutefir/files/digest-brutefir-1.0f b/media-sound/brutefir/files/digest-brutefir-1.0f
new file mode 100644
index 000000000000..969ae1ff585b
--- /dev/null
+++ b/media-sound/brutefir/files/digest-brutefir-1.0f
@@ -0,0 +1 @@
+MD5 2d06643ad908a351b1d5f987ae139fd6 brutefir-1.0f.tar.gz 235634