summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-08-24 09:19:00 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-08-24 09:19:00 +0000
commitee5ce2cbacacb11764709a6525c0ade0c68d315e (patch)
tree7f4890536d0bd32d2063a5a186cfa9bbff9c1c34 /media-sound/k3guitune/k3guitune-0.5.ebuild
parentlcms is not used only by imagemagick (diff)
downloadhistorical-ee5ce2cbacacb11764709a6525c0ade0c68d315e.tar.gz
historical-ee5ce2cbacacb11764709a6525c0ade0c68d315e.tar.bz2
historical-ee5ce2cbacacb11764709a6525c0ade0c68d315e.zip
New version.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-sound/k3guitune/k3guitune-0.5.ebuild')
-rw-r--r--media-sound/k3guitune/k3guitune-0.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/k3guitune/k3guitune-0.5.ebuild b/media-sound/k3guitune/k3guitune-0.5.ebuild
new file mode 100644
index 000000000000..a9d951be14c7
--- /dev/null
+++ b/media-sound/k3guitune/k3guitune-0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/k3guitune-0.5.ebuild,v 1.1 2005/08/24 09:19:00 greg_g Exp $
+
+inherit kde eutils
+
+DESCRIPTION="A program for KDE that lets you tune musical instruments."
+HOMEPAGE="http://home.planet.nl/~lamer024/k3guitune.html"
+SRC_URI="http://home.planet.nl/~lamer024/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="alsa arts oss"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+
+need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ use arts || epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_compile() {
+ # the test for jack always fails.
+ local myconf="$(use_enable alsa) $(use_enable arts)
+ $(use_enable oss) --disable-jack"
+
+ kde_src_compile
+}