summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-05-08 11:10:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-05-08 11:10:52 +0000
commite5fc9d731afd7079292378766878f109649d2cc5 (patch)
treedff6a1c2c031d389c5902a09cc74dc236f1386d7 /media-sound/lingot/lingot-0.7.6.ebuild
parentRemove unnecessary/redundant dependencies on libXaw and printproto. (diff)
downloadhistorical-e5fc9d731afd7079292378766878f109649d2cc5.tar.gz
historical-e5fc9d731afd7079292378766878f109649d2cc5.tar.bz2
historical-e5fc9d731afd7079292378766878f109649d2cc5.zip
Initial commit for bug 188845, thanks to gutter.
Package-Manager: portage-2.1.5_rc7
Diffstat (limited to 'media-sound/lingot/lingot-0.7.6.ebuild')
-rw-r--r--media-sound/lingot/lingot-0.7.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/lingot/lingot-0.7.6.ebuild b/media-sound/lingot/lingot-0.7.6.ebuild
new file mode 100644
index 000000000000..7daa6ff5c26e
--- /dev/null
+++ b/media-sound/lingot/lingot-0.7.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/lingot-0.7.6.ebuild,v 1.1 2008/05/08 11:10:51 drac Exp $
+
+WANT_AUTOMAKE=1.9
+
+inherit autotools eutils
+
+DESCRIPTION="LINGOT Is Not a Guitar-Only Tuner"
+HOMEPAGE="http://www.nongnu.org/lingot"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-clean-install.patch
+ eautomake
+}
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" libgotdocdir="/usr/share/doc/${PF}" \
+ install || die "emake install failed."
+ prepalldocs
+}