summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 22:44:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 22:44:18 +0000
commit9e6e0152e512d975c79af867d05f48bff4fcb511 (patch)
treeaa1273528ad69b22398aa0667440105d9320a46c /media-sound/mad
parentrelink fix (diff)
downloadhistorical-9e6e0152e512d975c79af867d05f48bff4fcb511.tar.gz
historical-9e6e0152e512d975c79af867d05f48bff4fcb511.tar.bz2
historical-9e6e0152e512d975c79af867d05f48bff4fcb511.zip
Added USE dependent nls compilation
Diffstat (limited to 'media-sound/mad')
-rw-r--r--media-sound/mad/ChangeLog8
-rw-r--r--media-sound/mad/files/digest-mad-0.14.2b-r11
-rw-r--r--media-sound/mad/mad-0.14.2b-r1.ebuild31
3 files changed, 39 insertions, 1 deletions
diff --git a/media-sound/mad/ChangeLog b/media-sound/mad/ChangeLog
index b060807ef21a..b7a8d9461652 100644
--- a/media-sound/mad/ChangeLog
+++ b/media-sound/mad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mad
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/ChangeLog,v 1.1 2002/02/01 21:53:31 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/ChangeLog,v 1.2 2002/03/12 22:44:18 seemant Exp $
+
+*mad-0.14.2b (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
+
+ Added USE dependent nls compilation
*mad-0.14.2b (1 Feb 2002)
diff --git a/media-sound/mad/files/digest-mad-0.14.2b-r1 b/media-sound/mad/files/digest-mad-0.14.2b-r1
new file mode 100644
index 000000000000..4d4bba1ea629
--- /dev/null
+++ b/media-sound/mad/files/digest-mad-0.14.2b-r1
@@ -0,0 +1 @@
+MD5 eb3bfbe634ba9d5b4928aa11e0f6819d mad-0.14.2b.tar.gz 721345
diff --git a/media-sound/mad/mad-0.14.2b-r1.ebuild b/media-sound/mad/mad-0.14.2b-r1.ebuild
new file mode 100644
index 000000000000..aa9aeb05f9af
--- /dev/null
+++ b/media-sound/mad/mad-0.14.2b-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/mad-0.14.2b-r1.ebuild,v 1.1 2002/03/12 22:44:18 seemant Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://mad.sourceforge.net/"
+DESCRIPTION="A high-quality MP3 decoder"
+
+DEPEND="sys-devel/gcc
+ virtual/glibc
+ sys-devel/ld.so
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc sys-devel/ld.so"
+
+src_compile() {
+ confopts="--infodir=/usr/share/info --mandir=/usr/share/man \
+ --prefix=/usr --host=${CHOST} --enable-static \
+ --disable-debugging --enable-shared --enable-fpm=intel"
+
+ use nls || confopts="${confopts} --disable-nls"
+
+ ./configure ${confopts} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}