summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-28 23:30:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-28 23:30:46 +0000
commit7f0f7bbb244dde1771a98de3a46cd0de0d12faf7 (patch)
treee10d16125597d00203ae1703139136488f5af555 /media-sound/mup
parentunmask mozilla-launcher-1.33 (diff)
downloadhistorical-7f0f7bbb244dde1771a98de3a46cd0de0d12faf7.tar.gz
historical-7f0f7bbb244dde1771a98de3a46cd0de0d12faf7.tar.bz2
historical-7f0f7bbb244dde1771a98de3a46cd0de0d12faf7.zip
fix use invocation
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-sound/mup')
-rw-r--r--media-sound/mup/Manifest8
-rw-r--r--media-sound/mup/mup-5.0.ebuild16
2 files changed, 12 insertions, 12 deletions
diff --git a/media-sound/mup/Manifest b/media-sound/mup/Manifest
index 4befc47e21a2..b864bc970c59 100644
--- a/media-sound/mup/Manifest
+++ b/media-sound/mup/Manifest
@@ -1,10 +1,10 @@
-MD5 40e63288102b3fb76597b1a79489702a ChangeLog 1698
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 e540a03623502ec54a08607a76afe596 mup-4.4.ebuild 2106
+MD5 19e75097eb2a7f3a87c816559b948128 mup-5.0.ebuild 2122
MD5 67d88a38f3b52922fe1b0706bd388f63 mup-4.6.ebuild 2137
-MD5 cfa766f360e91539d75412b0f6be4244 mup-5.0.ebuild 2188
-MD5 d73a9c5effa0eb340ee9eb4b799e32b8 files/4.6-gcc.patch 272
+MD5 40e63288102b3fb76597b1a79489702a ChangeLog 1698
MD5 234ec2d99e4c992ccc12fa76de885a0e files/5.0-beaming-bug.patch 928
+MD5 d73a9c5effa0eb340ee9eb4b799e32b8 files/4.6-gcc.patch 272
+MD5 631bd9db6b998acd073dbeae3e9cc0b8 files/digest-mup-5.0 120
MD5 3cdff463ef32c2e7b16982e0db999cfa files/digest-mup-4.4 120
MD5 54c05300dd4879fbf61504bc145fc1ef files/digest-mup-4.6 120
-MD5 631bd9db6b998acd073dbeae3e9cc0b8 files/digest-mup-5.0 120
diff --git a/media-sound/mup/mup-5.0.ebuild b/media-sound/mup/mup-5.0.ebuild
index 44d3fe546ec0..d1f6d5e71f5e 100644
--- a/media-sound/mup/mup-5.0.ebuild
+++ b/media-sound/mup/mup-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-5.0.ebuild,v 1.2 2005/05/15 14:44:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-5.0.ebuild,v 1.3 2005/06/28 23:30:46 mr_bones_ Exp $
inherit eutils toolchain-funcs
@@ -34,14 +34,14 @@ src_compile() {
echo $(tc-getCC) ${CFLAGS} -o mkmupfnt *.c
$(tc-getCC) ${CFLAGS} -o mkmupfnt *.c || die "mkmupfnt compile failed"
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
cd ${S}/mupdisp
- if [ `use X` ] ; then
+ if use X ; then
param="-lX11 -L/usr/X11R6/lib"
else
sed -i '/XWINDOW/s:.*::' dispttyp.h
fi
- if [ `use svga` ] ; then
+ if use svga ; then
param="${param} -lvga"
else
param="${param} -DNO_VGA_LIB"
@@ -53,7 +53,7 @@ src_compile() {
src_install() {
dobin mup/mup mkmupfnt/mkmupfnt mupprnt || die
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
dobin mupdisp/mupdisp || die
fi
@@ -61,7 +61,7 @@ src_install() {
cd docs
dodoc *.txt README1
doman mup.1 mkmupfnt.1 mupprnt.1
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
doman mupdisp.1
fi
dohtml uguide/*
@@ -70,7 +70,7 @@ src_install() {
}
pkg_postinst() {
- if [ `use svga` ] ; then
+ if use svga ; then
einfo "Please note that using mupdisp in SVGA mode on the console"
einfo "requires that it can write to the console device. To allow"
einfo "this, make mupdisp setuid to root, like this:"
@@ -78,7 +78,7 @@ pkg_postinst() {
einfo "\tchown root:root /usr/bin/mupdisp"
einfo "\tchmod u+s /usr/bin/mupdisp"
fi
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
echo
einfo "If you want to use mupdisp, make sure you also install ghostscript."
fi