summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2005-05-29 23:35:00 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2005-05-29 23:35:00 +0000
commite85d14750da00e0de67b97b00976754e76e420ee (patch)
treeb501a20dfbe0abb4a123c5ca7e6a8b4307216dc3 /media-sound/qsampler/qsampler-0.1.0.ebuild
parentNew ebuild for LinuxSampler (diff)
downloadhistorical-e85d14750da00e0de67b97b00976754e76e420ee.tar.gz
historical-e85d14750da00e0de67b97b00976754e76e420ee.tar.bz2
historical-e85d14750da00e0de67b97b00976754e76e420ee.zip
New ebuild for qsampler, a graphical frontend to LinuxSampler
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'media-sound/qsampler/qsampler-0.1.0.ebuild')
-rw-r--r--media-sound/qsampler/qsampler-0.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/qsampler/qsampler-0.1.0.ebuild b/media-sound/qsampler/qsampler-0.1.0.ebuild
new file mode 100644
index 000000000000..7ffb8bd2d607
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2005-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/qsampler-0.1.0.ebuild,v 1.1 2005/05/29 23:35:00 fvdpol Exp $
+
+inherit kde eutils
+
+DESCRIPTION="QSampler is a graphical frontent to the LinuxSampler engine."
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="virtual/libc
+ >=x11-libs/qt-3.1.1
+ >=media-libs/liblscp-0.2.9
+ >=media-libs/libgig-2.0.0
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}"
+#S="${WORKDIR}/${PN}"
+
+src_compile() {
+ econf || die "./configure failed"
+
+
+ ### borrowed from kde.eclass #
+ #
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox,
+ # so that the build process can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog INSTALL README
+}