summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-16 15:18:38 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-16 15:18:38 +0000
commit69cd813a73cbb6b69852bd1b31ab77bee20c5b86 (patch)
treea5ee0ba1960f86743f238efcccc651d35345f22a /media-sound/xmms-arts
parentFixed unpack and SRC_URI bugs (diff)
downloadhistorical-69cd813a73cbb6b69852bd1b31ab77bee20c5b86.tar.gz
historical-69cd813a73cbb6b69852bd1b31ab77bee20c5b86.tar.bz2
historical-69cd813a73cbb6b69852bd1b31ab77bee20c5b86.zip
*** empty log message ***
Diffstat (limited to 'media-sound/xmms-arts')
-rw-r--r--media-sound/xmms-arts/xmms-arts-0.4.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/media-sound/xmms-arts/xmms-arts-0.4.ebuild b/media-sound/xmms-arts/xmms-arts-0.4.ebuild
index a618a1f19817..808cd16d903d 100644
--- a/media-sound/xmms-arts/xmms-arts-0.4.ebuild
+++ b/media-sound/xmms-arts/xmms-arts-0.4.ebuild
@@ -1,28 +1,31 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms-arts/xmms-arts-0.4.ebuild,v 1.2 2001/01/16 06:36:06 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms-arts/xmms-arts-0.4.ebuild,v 1.3 2001/01/16 15:18:38 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="This output plugin allows xmms to work with arts, KDE's sound system"
SRC_URI="http://home.earthlink.net/~bheath/xmms-arts/xmmsarts-0.4.tar.gz"
+HOMEPAGE="http://home.earthlink.net/~bheath/xmms-arts/"
DEPEND=">=sys-libs/glibc-2.1.3 >=media-sound/xmms-1.2.3 >=kde-base/kde-2.0.1"
src_unpack() {
unpack ${A}
cd ${S}
- cp configure.in configure.in.orig
- sed -e 's:^CFLAGS="$CFLAGS $GLIB_CFLAGS":CFLAGS="$CFLAGS $GLIB_CFLAGS -I/usr/X11R6/include":' configure.in.orig > configure.in
- for x in Makefile.in Makefile.am
- do
- cp ${x} ${x}.orig
- sed -e 's:artsc-config:/opt/kde2/bin/artsc-config:g' ${x}.orig > ${x}
- done
+ cp Makefile.am Makefile.orig
+ sed -e "s:artsc-config:/opt/kde2/bin/artsc-config:" Makefile.orig > Makefile.am
autoconf
}
src_compile() {
- try ./configure --prefix=/usr/X11R6
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--prefix=/opt/gnome"
+ else
+ myconf="--prefix=/usr/X11R6"
+ fi
+ try CFLAGS=\"$CFLAGS -I/usr/X11R6/include -I/opt/gnome/include\" ./configure $myconf --host=${CHOST}
try make
}