summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-04 07:56:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-04 07:56:17 +0000
commit399611a3112f25836c6dc530619ec4d5daf97aba (patch)
tree228136789cafc84dc1522fd8490fc994f4f18cfe /media-sound/zynaddsubfx
parentaacgain is no more wrt #277801. (diff)
downloadhistorical-399611a3112f25836c6dc530619ec4d5daf97aba.tar.gz
historical-399611a3112f25836c6dc530619ec4d5daf97aba.tar.bz2
historical-399611a3112f25836c6dc530619ec4d5daf97aba.zip
Fix build with no useflag enabled, bug #283267
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/ChangeLog6
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.4.0-nullmidiin.patch26
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/media-sound/zynaddsubfx/ChangeLog b/media-sound/zynaddsubfx/ChangeLog
index 52b4ab39e96e..ec55371ae67e 100644
--- a/media-sound/zynaddsubfx/ChangeLog
+++ b/media-sound/zynaddsubfx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/zynaddsubfx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.34 2009/08/10 07:28:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.35 2009/09/04 07:56:17 aballier Exp $
+
+ 04 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ zynaddsubfx-2.4.0.ebuild, +files/zynaddsubfx-2.4.0-nullmidiin.patch:
+ Fix build with no useflag enabled, bug #283267
*zynaddsubfx-2.4.0 (10 Aug 2009)
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.0-nullmidiin.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.0-nullmidiin.patch
new file mode 100644
index 000000000000..261bb1b656f5
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.0-nullmidiin.patch
@@ -0,0 +1,26 @@
+Index: ZynAddSubFX-2.4.0/src/Input/NULLMidiIn.cpp
+===================================================================
+--- ZynAddSubFX-2.4.0.orig/src/Input/NULLMidiIn.cpp
++++ ZynAddSubFX-2.4.0/src/Input/NULLMidiIn.cpp
+@@ -34,7 +34,7 @@ NULLMidiIn::~NULLMidiIn()
+ * Get the midi command,channel and parameters
+ * It returns MidiNull because it is a dummy driver
+ */
+-void NULLMidiIn::getmidicmd(MidiCmdType &cmdtype,unsigned char &cmdchan,unsigned char *cmdparams)
++void NULLMidiIn::getmidicmd(MidiCmdType &cmdtype,unsigned char &cmdchan,int *cmdparams)
+ {
+ cmdtype=MidiNull;
+ };
+Index: ZynAddSubFX-2.4.0/src/Input/NULLMidiIn.h
+===================================================================
+--- ZynAddSubFX-2.4.0.orig/src/Input/NULLMidiIn.h
++++ ZynAddSubFX-2.4.0/src/Input/NULLMidiIn.h
+@@ -39,7 +39,7 @@ public:
+ /**Get the midi command,channel and parameters
+ * It returns MidiNull because it is a dummy driver
+ */
+- void getmidicmd(MidiCmdType &cmdtype,unsigned char &cmdchan,unsigned char *cmdparams);
++ void getmidicmd(MidiCmdType &cmdtype,unsigned char &cmdchan,int *cmdparams);
+
+ private:
+ };
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild
index 3bdff26dd6fc..e2c24c5fc65a 100644
--- a/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild
+++ b/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild,v 1.1 2009/08/10 07:28:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/zynaddsubfx-2.4.0.ebuild,v 1.2 2009/09/04 07:56:16 aballier Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -42,6 +42,7 @@ src_prepare() {
-i "${S}/ExternalPrograms/Controller/Makefile" || die
epatch "${FILESDIR}/${P}-string.patch"
epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-nullmidiin.patch"
}
use_echo_yesno() {