summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-06 00:55:38 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-06 00:55:38 +0000
commit46261c866c15b9dac0e56af1224ca2ce186e95c5 (patch)
tree1c9d7eb2dae50f1e305a6a39ec65f8bc8750b1cf /media-sound
parentNew package (diff)
downloadhistorical-46261c866c15b9dac0e56af1224ca2ce186e95c5.tar.gz
historical-46261c866c15b9dac0e56af1224ca2ce186e95c5.tar.bz2
historical-46261c866c15b9dac0e56af1224ca2ce186e95c5.zip
New package
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms-shell/ChangeLog11
-rw-r--r--media-sound/xmms-shell/files/digest-xmms-shell-0.99.01
-rw-r--r--media-sound/xmms-shell/xmms-shell-0.99.0.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/xmms-shell/ChangeLog b/media-sound/xmms-shell/ChangeLog
new file mode 100644
index 000000000000..548851a0e629
--- /dev/null
+++ b/media-sound/xmms-shell/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/xmms-shell
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms-shell/ChangeLog,v 1.1 2002/05/06 00:55:38 rphillips Exp $
+
+ 5 May 2002; Ryan Phillips <rphillips@gentoo.org> xmms-shell-0.99.0.ebuild :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-sound/xmms-shell/files/digest-xmms-shell-0.99.0 b/media-sound/xmms-shell/files/digest-xmms-shell-0.99.0
new file mode 100644
index 000000000000..9ac88339d0d0
--- /dev/null
+++ b/media-sound/xmms-shell/files/digest-xmms-shell-0.99.0
@@ -0,0 +1 @@
+MD5 a1685669f12770fbce0ea412e4e8e7da xmms-shell-0.99.0.tar.gz 51914
diff --git a/media-sound/xmms-shell/xmms-shell-0.99.0.ebuild b/media-sound/xmms-shell/xmms-shell-0.99.0.ebuild
new file mode 100644
index 000000000000..e267744fe84c
--- /dev/null
+++ b/media-sound/xmms-shell/xmms-shell-0.99.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: David Leal <david@l8f.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.5 2002/04/29 22:56:53 sandymac Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+SRC_URI="http://download.sourceforge.net/xmms-shell/xmms-shell-0.99.0.tar.gz"
+HOMEPAGE="http://www.loganh.com/xmms-shell/"
+LICENSE="GPL"
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
+
+src_compile() {
+ local myopts
+
+ use readline \
+ && myopts="${myopts} --with-readline" \
+ || myopts="${myopts} --without-readline"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myopts} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS README
+}