summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-31 14:17:30 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-31 14:17:30 +0000
commit95ee8f2b9286b08b6bb4e9ee426f664ea5f3f550 (patch)
tree38348f68f1d60aff736fea25e25b85736c4016fd /media-sound
parentVersion bumped & changed SRC_RI to sf (diff)
downloadhistorical-95ee8f2b9286b08b6bb4e9ee426f664ea5f3f550.tar.gz
historical-95ee8f2b9286b08b6bb4e9ee426f664ea5f3f550.tar.bz2
historical-95ee8f2b9286b08b6bb4e9ee426f664ea5f3f550.zip
Version bumped & changed SRC_RI to sf
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/Manifest6
-rw-r--r--media-sound/mpd/files/digest-mpd-0.9.31
-rw-r--r--media-sound/mpd/mpd-0.9.2.ebuild5
-rw-r--r--media-sound/mpd/mpd-0.9.3.ebuild46
4 files changed, 53 insertions, 5 deletions
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
index 64f6ba2fb5b7..0d90a29eea2f 100644
--- a/media-sound/mpd/Manifest
+++ b/media-sound/mpd/Manifest
@@ -1,8 +1,8 @@
-MD5 0dd32be8b2a669046e0d9364ede59332 ChangeLog 1245
+MD5 82732d685b79d91f33c7fdec9cadf287 ChangeLog 1400
MD5 521ed12f51bad08123003f61e32f6318 mpd-0.9.1.ebuild 1176
MD5 fec2bd71cbde59bd5f0232513e74bf6d mpd-0.8.7.ebuild 1106
-MD5 342197a1ec63875ac9ec0cbe712277dc mpd-0.9.2.ebuild 1189
-MD5 342197a1ec63875ac9ec0cbe712277dc mpd-0.9.3.ebuild 1189
+MD5 ab5e6f092e72a5e37250d833a4b574f1 mpd-0.9.2.ebuild 1189
+MD5 ee2e705692bd3c3841883d21106a80b2 mpd-0.9.3.ebuild 1189
MD5 823abc1f0601805ec678fc4db77c721e files/digest-mpd-0.9.1 61
MD5 88a28930c8cdfa9864f50dc50505cb84 files/digest-mpd-0.8.7 61
MD5 92faee86ed7d721d2df12ac46f428e3f files/digest-mpd-0.9.2 62
diff --git a/media-sound/mpd/files/digest-mpd-0.9.3 b/media-sound/mpd/files/digest-mpd-0.9.3
new file mode 100644
index 000000000000..7b098e1e496b
--- /dev/null
+++ b/media-sound/mpd/files/digest-mpd-0.9.3
@@ -0,0 +1 @@
+MD5 c27310fad56548fab37b24eec1ec6ce8 mpd-0.9.3.tar.gz 1012796
diff --git a/media-sound/mpd/mpd-0.9.2.ebuild b/media-sound/mpd/mpd-0.9.2.ebuild
index 59d5dd2fdae3..3cdaed124419 100644
--- a/media-sound/mpd/mpd-0.9.2.ebuild
+++ b/media-sound/mpd/mpd-0.9.2.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.9.2.ebuild,v 1.1 2003/10/08 20:36:42 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.9.2.ebuild,v 1.2 2003/10/31 14:17:25 mholzer Exp $
IUSE="oggvorbis mad"
DESCRIPTION="Music Player Daemon (mpd)"
-SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+RESTRICT="nomirror"
HOMEPAGE="http://www.musicpd.org"
KEYWORDS="~x86"
diff --git a/media-sound/mpd/mpd-0.9.3.ebuild b/media-sound/mpd/mpd-0.9.3.ebuild
new file mode 100644
index 000000000000..ed3824a8c5eb
--- /dev/null
+++ b/media-sound/mpd/mpd-0.9.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.9.3.ebuild,v 1.1 2003/10/31 14:17:25 mholzer Exp $
+
+IUSE="oggvorbis mad"
+
+DESCRIPTION="Music Player Daemon (mpd)"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.musicpd.org"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ mad? ( media-sound/mad )
+ >=media-libs/flac-1.1.0
+ media-libs/libao
+ sys-libs/zlib"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest \
+ --disable-vorbistest"
+ use mad || myconf="${myconf} --enable-mpd-mad --enable-mpd-id3tag"
+
+ econf ${myconf} || die "could not configure"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ rm -rf ${D}/usr/share/doc/mpd/
+ dodoc COPYING ChangeLog INSTALL README TODO UPGRADING
+ dodoc doc/COMMANDS doc/mpdconf.example
+}
+
+pkg_postinst() {
+ einfo "libao has issues with the ALSA drivers, please refer to the FAQ"
+ einfo "http://musicpd.sourceforge.net/faq.php"
+}