summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-16 19:29:52 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-16 19:29:52 +0000
commitb1d635754b6418ab954bdb4b81c59beaf714e99d (patch)
treeb47979eb4cccb58e90b73ec953f59fd2817bcc56 /media-sound
parentMissed changelog. (diff)
downloadhistorical-b1d635754b6418ab954bdb4b81c59beaf714e99d.tar.gz
historical-b1d635754b6418ab954bdb4b81c59beaf714e99d.tar.bz2
historical-b1d635754b6418ab954bdb4b81c59beaf714e99d.zip
Add fix for bug 227447, wrongly sized icon with vertical panel.
Package-Manager: portage-2.1.5.5
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/banshee/ChangeLog9
-rw-r--r--media-sound/banshee/banshee-1.0.0-r1.ebuild (renamed from media-sound/banshee/banshee-1.0.0.ebuild)12
-rw-r--r--media-sound/banshee/files/banshee-1.0.0-notification-icon.patch27
3 files changed, 45 insertions, 3 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 1d7dcb2f46f7..1ce6567136e4 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.61 2008/06/16 13:35:01 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.62 2008/06/16 19:29:51 loki_val Exp $
+
+*banshee-1.0.0-r1 (16 Jun 2008)
+
+ 16 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/banshee-1.0.0-notification-icon.patch, -banshee-1.0.0.ebuild,
+ +banshee-1.0.0-r1.ebuild:
+ Add fix for bug 227447, wrongly sized icon with vertical panel.
16 Jun 2008; Samuli Suominen <drac@gentoo.org> banshee-1.0.0.ebuild:
Sane USE defaults; most people don't own removable devices like ipod and
diff --git a/media-sound/banshee/banshee-1.0.0.ebuild b/media-sound/banshee/banshee-1.0.0-r1.ebuild
index 57900fd8c4e8..06c7e6c0916a 100644
--- a/media-sound/banshee/banshee-1.0.0.ebuild
+++ b/media-sound/banshee/banshee-1.0.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.0.0.ebuild,v 1.4 2008/06/16 13:35:01 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.0.0-r1.ebuild,v 1.1 2008/06/16 19:29:51 loki_val Exp $
EAPI=1
-inherit gnome2 mono
+inherit base gnome2 mono
GVER=0.10.3
@@ -69,6 +69,8 @@ RDEPEND=">=dev-lang/mono-1.2.4
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-notification-icon.patch" )
+
DOCS="AUTHORS ChangeLog HACKING NEWS README"
S=${WORKDIR}/${PN}-1-${PV}
@@ -84,3 +86,9 @@ pkg_setup() {
MAKEOPTS="${MAKEOPTS} -j1"
}
+
+src_unpack() {
+ base_src_unpack
+ gnome2_omf_fix
+ elibtoolize
+}
diff --git a/media-sound/banshee/files/banshee-1.0.0-notification-icon.patch b/media-sound/banshee/files/banshee-1.0.0-notification-icon.patch
new file mode 100644
index 000000000000..5de432da6287
--- /dev/null
+++ b/media-sound/banshee/files/banshee-1.0.0-notification-icon.patch
@@ -0,0 +1,27 @@
+If the panel in which the notification area sits is vertical, the icon size
+will be set to abnormally big. Changing panel to horizontal then back to
+vertical returns to a normal-sized icon.
+Bug has been reported upstream[1] and a patch is available.
+Patch is attached to this bug report.
+Tried in overlay with adding patch. It compiles and runs fine.
+
+[1]: http://bugzilla.gnome.org/show_bug.cgi?id=537679
+
+Index: src/Extensions/Banshee.NotificationArea/Banshee.NotificationArea/X11NotificationAreaBox.cs
+===================================================================
+--- src/Extensions/Banshee.NotificationArea/Banshee.NotificationArea/X11NotificationAreaBox.cs (revision 4138)
++++ src/Extensions/Banshee.NotificationArea/Banshee.NotificationArea/X11NotificationAreaBox.cs (working copy)
+@@ -149,11 +149,11 @@
+ // Determine whether the tray is inside a horizontal or vertical
+ // panel so the size of the icon can adjust correctly.
+
+- if (ParentWindow == null) {
++ if (event_box.ParentWindow == null) {
+ return PanelOrientation.Horizontal;
+ }
+
+- Gdk.Window top_level_window = ParentWindow.Toplevel;
++ Gdk.Window top_level_window = event_box.ParentWindow.Toplevel;
+
+ Gdk.Rectangle rect = top_level_window.FrameExtents;
+ if (rect.Width < rect.Height) {