summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
commitdb3fd00c0080a9202dcbb2ff8081db019535fc74 (patch)
tree290ac84daee8708cf2be9a58ec3e323967376088 /media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
parentFix quoting, stop using ./configure (#120887) (diff)
downloadhistorical-db3fd00c0080a9202dcbb2ff8081db019535fc74.tar.gz
historical-db3fd00c0080a9202dcbb2ff8081db019535fc74.tar.bz2
historical-db3fd00c0080a9202dcbb2ff8081db019535fc74.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. Package-Manager: portage-2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686
Diffstat (limited to 'media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild')
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
index 85cf5b78dfa6..fe595dd44065 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild,v 1.2 2007/12/11 23:16:07 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild,v 1.3 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -66,12 +66,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -96,7 +102,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"