summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2005-08-13 12:06:17 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2005-08-13 12:06:17 +0000
commit5b4a459746102fb7c5388ec7913fe72b4e8b54e9 (patch)
tree9d052db3536acdc9a48a877140ed9004fb78ae81 /media-tv/gentoo-vdr-scripts
parentmedia-video/DFBSee is replaced by media-video/dfbsee. (diff)
downloadhistorical-5b4a459746102fb7c5388ec7913fe72b4e8b54e9.tar.gz
historical-5b4a459746102fb7c5388ec7913fe72b4e8b54e9.tar.bz2
historical-5b4a459746102fb7c5388ec7913fe72b4e8b54e9.zip
added patch to correct ugly behaviour when creating commands.conf
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-tv/gentoo-vdr-scripts')
-rw-r--r--media-tv/gentoo-vdr-scripts/ChangeLog7
-rw-r--r--media-tv/gentoo-vdr-scripts/Manifest5
-rw-r--r--media-tv/gentoo-vdr-scripts/files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff58
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild9
4 files changed, 75 insertions, 4 deletions
diff --git a/media-tv/gentoo-vdr-scripts/ChangeLog b/media-tv/gentoo-vdr-scripts/ChangeLog
index ba0d639389a7..190c1987404d 100644
--- a/media-tv/gentoo-vdr-scripts/ChangeLog
+++ b/media-tv/gentoo-vdr-scripts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/gentoo-vdr-scripts
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/ChangeLog,v 1.1 2005/08/13 09:03:38 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/ChangeLog,v 1.2 2005/08/13 12:06:17 zzam Exp $
+
+ 13 Aug 2005; Matthias Schwarzott <zzam@gentoo.org>
+ +files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff,
+ gentoo-vdr-scripts-0.1_alpha1.ebuild:
+ added patch to correct ugly behaviour when creating commands.conf
*gentoo-vdr-scripts-0.1_alpha1 (13 Aug 2005)
diff --git a/media-tv/gentoo-vdr-scripts/Manifest b/media-tv/gentoo-vdr-scripts/Manifest
index c50e31e368a1..65b8a511dc0f 100644
--- a/media-tv/gentoo-vdr-scripts/Manifest
+++ b/media-tv/gentoo-vdr-scripts/Manifest
@@ -1,4 +1,5 @@
-MD5 14a8e1d99249c08ac216e089d1eca03f gentoo-vdr-scripts-0.1_alpha1.ebuild 705
-MD5 42d024dd16158ad03a8e8c06f42c46b7 ChangeLog 424
+MD5 d592479e8704429b4067062679e90006 gentoo-vdr-scripts-0.1_alpha1.ebuild 801
+MD5 54feaeb7bd652757fcd135cfd18eb8a6 ChangeLog 646
MD5 56a0b0ac7e6c5ab62c3e45c87a2f07d6 metadata.xml 255
+MD5 cc3806f7a39109c105d0603dc651edb4 files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff 1785
MD5 b8fba7f5ebd2c87f79834578f56c2a31 files/digest-gentoo-vdr-scripts-0.1_alpha1 76
diff --git a/media-tv/gentoo-vdr-scripts/files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff b/media-tv/gentoo-vdr-scripts/files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff
new file mode 100644
index 000000000000..b2eab8df6912
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/files/gentoo-vdr-scripts-0.1_alpha1-merge-commands.diff
@@ -0,0 +1,58 @@
+--- gentoo-vdr-scripts/usr/lib/vdr/rcscript/pre-start-40-create-commands-conf.sh.old 2005-08-13 13:56:13.000000000 +0200
++++ gentoo-vdr-scripts/usr/lib/vdr/rcscript/pre-start-40-create-commands-conf.sh 2005-08-13 12:46:37.000000000 +0200
+@@ -3,7 +3,7 @@
+ local bname="${1}"
+ local order="${2}"
+ local file="${CONFIG}/${bname}.conf"
+- local newfile="/var/vdr/${bname}.conf"
++ local mergedfile="/var/vdr/${bname}.conf"
+ local sdir="/etc/vdr/${bname}"
+
+ if [[ ! -L "${file}" ]]; then
+@@ -12,14 +12,16 @@
+ einfo "Saved original ${file} as ${file}.backup"
+ fi
+
+- ln -s "../../${newfile}" "${file}"
++ ln -s "../../${mergedfile}" "${file}"
+ fi
+
+- if ! rm "${newfile}"; then
+- ewarn "Could not change ${newfile}"
+- return
++ if [[ -f "${mergedfile}" ]]; then
++ if ! rm "${mergedfile}"; then
++ ewarn "Could not change ${mergedfile}"
++ return
++ fi
+ fi
+- cat > "${newfile}" <<-EOT
++ cat > "${mergedfile}" <<-EOT
+ # Warning: Do not change this file.
+ # This file is generated automatically by /etc/init.d/vdr.
+ # Change the source files under ${sdir}.
+@@ -29,15 +31,17 @@
+ SFILES=$(echo /etc/vdr/${bname}/${bname}.*.conf)
+ for f in ${SFILES}; do
+ [[ -f "${f}" ]] || continue
+- echo "# source : ${f}" >> "${newfile}"
+- cat "${f}" >> "${newfile}"
+- echo >> "${newfile}"
++ echo "# source : ${f}" >> "${mergedfile}"
++ cat "${f}" >> "${mergedfile}"
++ echo >> "${mergedfile}"
+ done
+ }
+
++ebegin "preparing vdr config files"
+ if [[ ! -d /var/vdr ]]; then
+- ewarn "directory /var/vdr does not exist"
+-else
+- create_commands_conf commands "${ORDER_COMMANDS}"
+- create_commands_conf reccmds "${ORDER_RECCMDS}"
++ mkdir -p /var/vdr
++ ewarn "created /var/vdr"
+ fi
++create_commands_conf commands "${ORDER_COMMANDS}"
++create_commands_conf reccmds "${ORDER_RECCMDS}"
++eend 0
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild
index 99abfef4ffbd..9544ad050aa2 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild,v 1.1 2005/08/13 09:03:38 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.1_alpha1.ebuild,v 1.2 2005/08/13 12:06:17 zzam Exp $
+
+inherit eutils
SRC_URI="mirrors://gentoo/${P}.tgz"
DESCRIPTION="scripts necessary for use of vdr as a set-top-box"
@@ -12,6 +14,11 @@ KEYWORDS="~x86"
S=${WORKDIR}/${PN}
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}/${P}-merge-commands.diff"
+}
+
src_install() {
cd ${S}
make install DESTDIR="${D}"