summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-04 17:57:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-04 17:57:10 +0000
commit454d634d75af4f01bf2f8a521dc3bec93ca16728 (patch)
treee6055cd431b0b3a709015b8e49dd84e735c2009c /media-tv/nvtv/nvtv-0.4.5.ebuild
parentcleanup (diff)
downloadhistorical-454d634d75af4f01bf2f8a521dc3bec93ca16728.tar.gz
historical-454d634d75af4f01bf2f8a521dc3bec93ca16728.tar.bz2
historical-454d634d75af4f01bf2f8a521dc3bec93ca16728.zip
gtk/gtk2 USE flag check fix
Diffstat (limited to 'media-tv/nvtv/nvtv-0.4.5.ebuild')
-rw-r--r--media-tv/nvtv/nvtv-0.4.5.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/media-tv/nvtv/nvtv-0.4.5.ebuild b/media-tv/nvtv/nvtv-0.4.5.ebuild
index 967f7b6edc31..e632b5f6051d 100644
--- a/media-tv/nvtv/nvtv-0.4.5.ebuild
+++ b/media-tv/nvtv/nvtv-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/nvtv-0.4.5.ebuild,v 1.2 2003/09/01 19:38:06 blauwers Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/nvtv-0.4.5.ebuild,v 1.3 2003/12/04 17:57:09 seemant Exp $
IUSE="X gtk gtk2"
@@ -13,24 +13,32 @@ LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="sys-apps/pciutils
- gtk? ( =x11-libs/gtk+-1.2* )
- gtk2? ( =x11-libs/gtk+-2* )
+ gtk? (
+ gtk2? ( =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ )
X? ( >=x11-base/xfree-4.0 )"
src_compile() {
local myconf
- if use gtk2; then
- myconf="${myconf} --with-gtk=gtk2"
- elif use gtk; then
- myconf="${myconf} --with-gtk=gtk1"
+ if use gtk
+ then
+ if use gtk2
+ then
+ myconf="${myconf} --with-gtk=gtk2"
+ else
+ myconf="${myconf} --with-gtk=gtk1"
+ fi
else
- myconf="${myconf} --without-gtk";
+ myconf="${myconf} --without-gtk"
fi
- use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
- econf ${myconf}
+ econf ${myconf} || die
# The CFLAGS don't seem to make it into the Makefile.
cd src