summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-07-07 19:01:51 +0000
committerLars Weiler <pylon@gentoo.org>2007-07-07 19:01:51 +0000
commit95aa2ebcf2c40490659c1b67784553a770b2c89b (patch)
treef67510d2b1ce89abd10b85e4f12ebc1f99b502b9 /media-tv/nxtvepg/nxtvepg-2.7.7.ebuild
parentClean up old versions, bump, revbump to fix install locations (diff)
downloadhistorical-95aa2ebcf2c40490659c1b67784553a770b2c89b.tar.gz
historical-95aa2ebcf2c40490659c1b67784553a770b2c89b.tar.bz2
historical-95aa2ebcf2c40490659c1b67784553a770b2c89b.zip
Version bump (better some months too late than never).
Package-Manager: portage-2.1.3_rc6
Diffstat (limited to 'media-tv/nxtvepg/nxtvepg-2.7.7.ebuild')
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.7.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild b/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild
new file mode 100644
index 000000000000..7ea1b99be24b
--- /dev/null
+++ b/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild,v 1.1 2007/07/07 19:01:51 pylon Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
+HOMEPAGE="http://nxtvepg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/tcl-8.0
+ >=dev-lang/tk-8.0
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-kernel/linux-headers
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/nxtvepg-db.patch"
+}
+
+src_compile() {
+ emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
+}
+
+src_install() {
+ emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
+ dodoc README CHANGES TODO
+ dohtml manual*.html
+}