summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-07 23:08:42 +0000
committerMax Kalika <max@gentoo.org>2003-08-07 23:08:42 +0000
commit98f14f0a66e8d2adfd3129f78029d800db21157c (patch)
treee43f2db9e4aa878f681d665a6bf5fc2eb093761a /media-tv
parentCPAN Version bump (diff)
downloadhistorical-98f14f0a66e8d2adfd3129f78029d800db21157c.tar.gz
historical-98f14f0a66e8d2adfd3129f78029d800db21157c.tar.bz2
historical-98f14f0a66e8d2adfd3129f78029d800db21157c.zip
Initial version.
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfrontend/ChangeLog9
-rw-r--r--media-tv/mythfrontend/Manifest3
-rw-r--r--media-tv/mythfrontend/files/digest-mythfrontend-0.101
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.10.ebuild66
4 files changed, 79 insertions, 0 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
new file mode 100644
index 000000000000..a151ecb83324
--- /dev/null
+++ b/media-tv/mythfrontend/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-tv/mythfrontend
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.1 2003/08/07 23:08:40 max Exp $
+
+*mythfrontend-0.10 (07 Aug 2003)
+
+ 07 Aug 2003; Max Kalika <max@gentoo.org> mythfrontend-0.10.ebuild:
+ Initial version.
+
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
new file mode 100644
index 000000000000..02f0d699b588
--- /dev/null
+++ b/media-tv/mythfrontend/Manifest
@@ -0,0 +1,3 @@
+MD5 2a3af223f727988473e989712c8045fc mythfrontend-0.10.ebuild 1488
+MD5 f124b81c579a895f1bc34707a3fe1a0c ChangeLog 344
+MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythfrontend-0.10 65
diff --git a/media-tv/mythfrontend/files/digest-mythfrontend-0.10 b/media-tv/mythfrontend/files/digest-mythfrontend-0.10
new file mode 100644
index 000000000000..6fbdb3de9d4c
--- /dev/null
+++ b/media-tv/mythfrontend/files/digest-mythfrontend-0.10
@@ -0,0 +1 @@
+MD5 3e6dad28e1c25929ceb124ad7d0a3d0b mythtv-0.10.tar.bz2 2466640
diff --git a/media-tv/mythfrontend/mythfrontend-0.10.ebuild b/media-tv/mythfrontend/mythfrontend-0.10.ebuild
new file mode 100644
index 000000000000..b5e7dfb03693
--- /dev/null
+++ b/media-tv/mythfrontend/mythfrontend-0.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.10.ebuild,v 1.1 2003/08/07 23:08:40 max Exp $
+
+inherit flag-o-matic
+
+IUSE="lcd"
+DESCRIPTION="Homebrew PVR project frontend."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3
+ >=media-sound/lame-3.92
+ >=media-libs/freetype-2.0
+ >=sys-apps/sed-4
+ lcd? ( app-misc/lcdproc )
+ !media-tv/mythtv"
+
+S="${WORKDIR}/mythtv-${PV}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr usr/local "${S}"` ; do
+ sed -e "s:usr/local:usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ -n "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/mythtv.pro"
+
+ econf `use_enable lcd`
+
+ # Parallel build doesn't work.
+ make || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ rm -rf "${D}"/usr/bin/myth{backend,commflag,filldatabase,transcode} \
+ "${D}"/usr/lib/mythtv "${D}"/usr/share/mythtv/setup.xml
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.txt
+ dohtml docs/*.html
+
+}