summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2004-08-11 10:51:30 +0000
committerAnders Rune Jensen <arj@gentoo.org>2004-08-11 10:51:30 +0000
commitfe74858f76c5a436759bb0fa6cf85aee6e911882 (patch)
tree0de5caf93eaad1e048837bf50e41082e2f248580 /media-video/em8300-modules/em8300-modules-0.14.0.ebuild
parentbump to fix #40420 (diff)
downloadhistorical-fe74858f76c5a436759bb0fa6cf85aee6e911882.tar.gz
historical-fe74858f76c5a436759bb0fa6cf85aee6e911882.tar.bz2
historical-fe74858f76c5a436759bb0fa6cf85aee6e911882.zip
new version
Diffstat (limited to 'media-video/em8300-modules/em8300-modules-0.14.0.ebuild')
-rw-r--r--media-video/em8300-modules/em8300-modules-0.14.0.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-video/em8300-modules/em8300-modules-0.14.0.ebuild b/media-video/em8300-modules/em8300-modules-0.14.0.ebuild
new file mode 100644
index 000000000000..5af9b9a79b40
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.14.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.14.0.ebuild,v 1.1 2004/08/11 10:50:10 arj Exp $
+
+S="${WORKDIR}/${A/.tar.gz/}/modules"
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${P/-modules/}.tar.gz"
+
+DEPEND="virtual/linux-sources"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${S}
+
+}
+
+src_compile () {
+
+ make all || die
+
+}
+
+src_install () {
+
+ insinto "/usr/include/linux"
+ doins ../include/linux/em8300.h
+
+ # The driver goes into the standard modules location
+ insinto "/lib/modules/${KV}/kernel/drivers/video"
+ doins em8300.o bt865.o adv717x.o
+
+ # Docs
+ dodoc README-modoptions \
+ README-modules.conf \
+ devfs_symlinks
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.em8300 em8300
+
+}
+
+pkg_postinst () {
+
+ if [ "${ROOT}" = "/" ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The em8300 kernel modules have been installed into the modules"
+ einfo "directory of your currently running kernel. They haven't been"
+ einfo "loaded. Please read the documentation, and if you would like"
+ einfo "to have the modules load at startup, add em8300, bt865, adv717x"
+ einfo "to your /etc/modules.autoload they may need module options to "
+ einfo "work correctly on your system. You will also need to add"
+ einfo "the contents of /usr/share/doc/${P}/devfs_symlinks.gz"
+ einfo "to your devfsd.conf so that the em8300 devices will be linked"
+ einfo "correctly."
+ einfo
+ einfo "You will also need to have the i2c kernel modules compiled for"
+ einfo "this to be happy, no need to patch any kernel though just turn"
+ einfo "all the i2c stuff in kernel config to M and you'll be fine."
+ einfo
+
+}