summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-01-03 12:15:04 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-01-03 12:15:04 +0000
commit4f2b9c4e4499633073229b5a12669095728c4d80 (patch)
treee640bdd3efec9b9291299f30121d2118f460136b /media-video/jahshaka/jahshaka-2.0_rc1.ebuild
parentUnmask transcode-1.0, let's see how much it breaks. (diff)
downloadhistorical-4f2b9c4e4499633073229b5a12669095728c4d80.tar.gz
historical-4f2b9c4e4499633073229b5a12669095728c4d80.tar.bz2
historical-4f2b9c4e4499633073229b5a12669095728c4d80.zip
Fix compilation with qt4 on the system
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'media-video/jahshaka/jahshaka-2.0_rc1.ebuild')
-rw-r--r--media-video/jahshaka/jahshaka-2.0_rc1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-video/jahshaka/jahshaka-2.0_rc1.ebuild b/media-video/jahshaka/jahshaka-2.0_rc1.ebuild
index ddd3a2bb609f..7c7751daaa66 100644
--- a/media-video/jahshaka/jahshaka-2.0_rc1.ebuild
+++ b/media-video/jahshaka/jahshaka-2.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/jahshaka/jahshaka-2.0_rc1.ebuild,v 1.4 2005/12/17 14:46:55 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/jahshaka/jahshaka-2.0_rc1.ebuild,v 1.5 2006/01/03 12:15:04 caleb Exp $
inherit eutils
@@ -29,14 +29,14 @@ RESTRICT="nostrip"
S="${WORKDIR}/${PN}"
src_compile() {
- sed -e "s/qmake/\$\{QTDIR\}\/bin\/qmake/" -i ${S}/configure
+ sed -e "s/qmake/\$\{QTDIR\}\/bin\/qmake QMAKE=\$\{QTDIR\}\/bin\/qmake/" -i ${S}/configure
./configure --prefix=/usr \
`use_enable static` \
`use_enable debug` \
|| die "configure failed"
cd ${S}/plugins
- ${QTDIR}/bin/qmake plugins.pro
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake plugins.pro
cd ${S}
make || die