summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-08-07 16:50:08 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-08-07 16:50:08 +0000
commita7f794d38249f442907551dfaf148cf5dd4d2452 (patch)
tree5d53a42e58c27ade30e1feaf35b18ad7cb5303c5 /media-video/kmplayer/kmplayer-0.9.0b.ebuild
parentFixed indexing with EMBOSS 3.0.0. (diff)
downloadhistorical-a7f794d38249f442907551dfaf148cf5dd4d2452.tar.gz
historical-a7f794d38249f442907551dfaf148cf5dd4d2452.tar.bz2
historical-a7f794d38249f442907551dfaf148cf5dd4d2452.zip
version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-video/kmplayer/kmplayer-0.9.0b.ebuild')
-rw-r--r--media-video/kmplayer/kmplayer-0.9.0b.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/kmplayer/kmplayer-0.9.0b.ebuild b/media-video/kmplayer/kmplayer-0.9.0b.ebuild
new file mode 100644
index 000000000000..f29c8ed94c53
--- /dev/null
+++ b/media-video/kmplayer/kmplayer-0.9.0b.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/kmplayer-0.9.0b.ebuild,v 1.1 2005/08/07 16:50:08 carlo Exp $
+
+inherit kde
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="MPlayer frontend for KDE"
+HOMEPAGE="http://www.xs4all.nl/~jjvrieze/kmplayer.html"
+SRC_URI="http://www.xs4all.nl/~jjvrieze/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gstreamer xine"
+
+# Removed koffice plugin, since the compilation fails and it's not supported upstream.
+DEPEND=">=media-video/mplayer-0.90
+ xine? ( >=media-libs/xine-lib-1_beta12 )
+ gstreamer? ( >=media-libs/gst-plugins-0.8.7 )"
+need-kde 3.1
+
+src_compile(){
+ local myconf="$(use_with gstreamer) $(use_with xine)"
+ kde_src_compile
+}