summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-20 23:13:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-20 23:13:34 +0000
commit667637e5c224feadcc91aec25dc9a4149c2ea80a (patch)
tree49b185bd53ed155ad864b128f85f605c06fb5e18 /media-video/lsdvd/files
parentFix libxklavier-4 support. (diff)
downloadhistorical-667637e5c224feadcc91aec25dc9a4149c2ea80a.tar.gz
historical-667637e5c224feadcc91aec25dc9a4149c2ea80a.tar.bz2
historical-667637e5c224feadcc91aec25dc9a4149c2ea80a.zip
Don't bail out when there is title reading errors wrt #233113 by Martin Thierer.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'media-video/lsdvd/files')
-rw-r--r--media-video/lsdvd/files/lsdvd-0.15-types.patch26
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-title.patch27
2 files changed, 27 insertions, 26 deletions
diff --git a/media-video/lsdvd/files/lsdvd-0.15-types.patch b/media-video/lsdvd/files/lsdvd-0.15-types.patch
deleted file mode 100644
index 9cb8e6422a0b..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.15-types.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: lsdvd-0.15/configure.in
-===================================================================
---- lsdvd-0.15.orig/configure.in
-+++ lsdvd-0.15/configure.in
-@@ -5,7 +5,8 @@ CFLAGS=-g
- AC_PROG_CC
- AC_CHECK_LIB(dvdread, DVDOpen, , AC_MSG_ERROR([libdvdread not found!]))
- AC_MSG_CHECKING([for dvdread/ifo_read.h])
--AC_TRY_COMPILE([#include <dvdread/ifo_read.h>], ,
-+AC_TRY_COMPILE([#include <stdint.h>
-+ #include <dvdread/ifo_read.h>], ,
- AC_MSG_RESULT([yes]),
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([Header files for dvdread not found]))
-Index: lsdvd-0.15/lsdvd.c
-===================================================================
---- lsdvd-0.15.orig/lsdvd.c
-+++ lsdvd-0.15/lsdvd.c
-@@ -13,6 +13,7 @@
- * 2003-04-19 Cleanups get_title_name, added dvdtime2msec, added helper macros,
- * output info structures in form of a Perl module, by Henk Vergonet.
- */
-+#include <stdint.h>
- #include <dvdread/ifo_read.h>
- #include <string.h>
- #include <sys/stat.h>
diff --git a/media-video/lsdvd/files/lsdvd-0.16-title.patch b/media-video/lsdvd/files/lsdvd-0.16-title.patch
new file mode 100644
index 000000000000..44511a126e64
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-title.patch
@@ -0,0 +1,27 @@
+See, http://bugs.gentoo.org/show_bug.cgi?id=233113
+
+lsdvd always reads the infos for all titles (even if only a single title was
+selected with "-t") and bails out if there is an error.
+
+Now, if for example title 5 is unreadable but you're interested in title 1, you
+should be able to get the info by using "-t 1", but that doesn't work, as lsdvd
+errors out before even starting the output because it can't read title 5.
+
+To solve this my patch makes lsdvd ignore read errors in titles it wouldn't
+display anyway.
+
+Patch by Martin Thierer
+
+diff -uw lsdvd-0.16.orig/lsdvd.c lsdvd-0.16/lsdvd.c
+--- lsdvd-0.16.orig/lsdvd.c 2006-03-02 14:48:11.000000000 +0100
++++ lsdvd-0.16/lsdvd.c 2008-07-27 20:11:55.000000000 +0200
+@@ -292,7 +292,7 @@
+
+ for (i=1; i <= ifo_zero->vts_atrt->nr_of_vtss; i++) {
+ ifo[i] = ifoOpen(dvd, i);
+- if ( !ifo[i] ) {
++ if ( !ifo[i] && opt_t == i ) {
+ fprintf( stderr, "Can't open ifo %d!\n", i);
+ return 4;
+ }
+