summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-28 01:46:17 +0000
committerChris White <chriswhite@gentoo.org>2005-01-28 01:46:17 +0000
commit59e8a1f500d2d61707a8942be2bc563587369dc8 (patch)
treed9521d24a892e7a84114c783b5d6194270deecda /media-video/mpgtx/mpgtx-1.3.1.ebuild
parentdrop eutils eclass depend (diff)
downloadhistorical-59e8a1f500d2d61707a8942be2bc563587369dc8.tar.gz
historical-59e8a1f500d2d61707a8942be2bc563587369dc8.tar.bz2
historical-59e8a1f500d2d61707a8942be2bc563587369dc8.zip
Bumped to 1.3.1. Fixes bug #79160. Thanks to Martin Deirs for the report.
Diffstat (limited to 'media-video/mpgtx/mpgtx-1.3.1.ebuild')
-rw-r--r--media-video/mpgtx/mpgtx-1.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-video/mpgtx/mpgtx-1.3.1.ebuild b/media-video/mpgtx/mpgtx-1.3.1.ebuild
new file mode 100644
index 000000000000..1a95922f6232
--- /dev/null
+++ b/media-video/mpgtx/mpgtx-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.1.ebuild,v 1.1 2005/01/28 01:46:17 chriswhite Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="mpgtx a command line MPEG audio/video/system file toolbox"
+SRC_URI="mirror://sourceforge/mpgtx/${P}.tar.gz"
+HOMEPAGE="http://mpgtx.sourceforge.net/"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="sys-libs/glibc"
+
+src_compile() {
+ ./configure --parachute --prefix=/usr
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]; then
+ sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe mpgtx
+
+ dosym /usr/bin/mpgtx /usr/bin/mpgjoin
+ dosym /usr/bin/mpgtx /usr/bin/mpgsplit
+ dosym /usr/bin/mpgtx /usr/bin/mpgcat
+ dosym /usr/bin/mpgtx /usr/bin/mpginfo
+ dosym /usr/bin/mpgtx /usr/bin/mpgdemux
+ dosym /usr/bin/mpgtx /usr/bin/tagmp3
+
+ doman man/mpgtx.1 man/tagmp3.1
+
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgcat.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgjoin.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpginfo.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgsplit.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgdemux.1
+
+ dodoc AUTHORS ChangeLog README TODO
+}