summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 02:25:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 02:25:52 +0000
commiteaee117d355bbdb3136b0653d253ca38ac3a07b8 (patch)
tree9223e9dfd132ac868cc0bb83c55402e39e58e774 /media-video/realplayer
parentbumps (diff)
downloadhistorical-eaee117d355bbdb3136b0653d253ca38ac3a07b8.tar.gz
historical-eaee117d355bbdb3136b0653d253ca38ac3a07b8.tar.bz2
historical-eaee117d355bbdb3136b0653d253ca38ac3a07b8.zip
menu entry fixes
Diffstat (limited to 'media-video/realplayer')
-rw-r--r--media-video/realplayer/ChangeLog10
-rw-r--r--media-video/realplayer/files/digest-realplayer-8-r51
-rw-r--r--media-video/realplayer/realplayer-8-r5.ebuild134
3 files changed, 144 insertions, 1 deletions
diff --git a/media-video/realplayer/ChangeLog b/media-video/realplayer/ChangeLog
index 900508f1b28b..b32b38e5d63c 100644
--- a/media-video/realplayer/ChangeLog
+++ b/media-video/realplayer/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for media-video/realplayer
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/ChangeLog,v 1.10 2003/01/14 21:51:12 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/ChangeLog,v 1.11 2003/02/10 02:25:52 seemant Exp $
+*realplayer-8-r5 (09 Feb 2003)
+
+ 09 Feb 2003; Seemant Kulleen <seemant@gentoo.org> realplayer-8-r5.ebuild
+ files/digest-realplayer-8-r5 :
+
+ Inherits kde eclass so that kde menu entries go into the right place, and
+ also fixes for gnome menu entries (needs a bit of verification)
+
*realplayer-8-r4 (08 Jan 2003)
14 Jan 2003; Martin Holzer <mholzer@gentoo.org> realplayer-8-r4.ebuild :
diff --git a/media-video/realplayer/files/digest-realplayer-8-r5 b/media-video/realplayer/files/digest-realplayer-8-r5
new file mode 100644
index 000000000000..4634aae6d8de
--- /dev/null
+++ b/media-video/realplayer/files/digest-realplayer-8-r5
@@ -0,0 +1 @@
+MD5 b2fd9f4148edfd8e2a714dd57634ae1b rv9_libc6_i386_cs2.tgz 814305
diff --git a/media-video/realplayer/realplayer-8-r5.ebuild b/media-video/realplayer/realplayer-8-r5.ebuild
new file mode 100644
index 000000000000..4cfd22f4e451
--- /dev/null
+++ b/media-video/realplayer/realplayer-8-r5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/realplayer-8-r5.ebuild,v 1.1 2003/02/10 02:25:52 seemant Exp $
+
+inherit nsplugins kde
+
+IUSE="kde gnome"
+
+DESCRIPTION="RealPlayer 8 is a streaming media player"
+HOMEPAGE="http://forms.real.com/real/player/unix/unix.html"
+
+# !! READ THIS !!
+# Due to fetch restrictions, you need to go to the above URL and fill out the
+# form in order to be able to download the binary. When done, you should copy
+# or move the binary into /usr/portage/distfiles. No need to chmod +x
+
+if use x86
+then
+ A="rp8_linux20_libc6_i386_cs2.bin"
+elif use ppc
+then
+ A="rp8_linux_powerpc_cs1.bin"
+elif use sparc
+then
+ A="rp8_linux_sparc_cs1.bin"
+elif use alpha
+then
+ A="rp8_linux_alpha_rh62_cs1.bin"
+fi
+
+
+SRC_URI="x86? http://docs.real.com/docs/playerpatch/unix/rv9_libc6_i386_cs2.tgz"
+
+LICENSE="realplayer8"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/x11"
+RESTRICT="nostrip"
+
+BASE="/opt/RealPlayer8"
+S=${WORKDIR}
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${A} ] ; then
+ eerror "Please go to:"
+ eerror "http://forms.real.com/real/player/unix/unix.html"
+ eerror "And download the appropriate realplayer binary installer"
+ eerror "for this architecture: ${ARCH}"
+ use x86 && \
+ eerror "Please note, do NOT download the rpm. Just the .bin file"
+ eerror "Named Linux 2.x (libc6 i386)"
+ eerror ""
+ eerror "Download ${A} and place it in ${DISTDIR}"
+ eerror "Then emerge this package again"
+
+ exit 1
+ fi
+}
+
+src_unpack() {
+ if use x86 ; then
+ BYTECOUNT=4799691
+ RP8_BIN=`echo ${A} | awk '{ print $1 }'`
+ RV9_X86=`echo ${A} | awk '{ print $2 }'`
+ else
+ RP8_BIN=${A}
+ if use ppc ; then BYTECOUNT=7260910
+ elif use alpha ; then BYTECOUNT=7130860
+ elif use sparc ; then BYTECOUNT=6375000
+ fi
+ fi
+ tail -c ${BYTECOUNT} ${DISTDIR}/${RP8_BIN} | tar xz 2> /dev/null
+ if use x86 ; then
+ unpack ${RV9_X86}
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to Compile, this is a binary package"
+}
+
+src_install () {
+ insinto ${BASE}/Codecs
+ doins Codecs/*
+ if [ -d rv9/codecs ] ; then
+ doins rv9/codecs/drv4.so.6.0 rv9/codecs/rv40.so.6.0
+ fi
+ insinto ${BASE}/Common
+ doins Common/*
+ insinto ${BASE}/Plugins/ExtResources
+ doins Plugins/ExtResources/*
+ insinto ${BASE}/Plugins
+ doins Plugins/*.so.6.0
+ insinto ${BASE}
+ doins *.xpm *.png *.rm rpnp.so LICENSE README ${FILESDIR}/mimeinfo
+ exeinto ${BASE}
+ doexe realplay
+ dodir /opt/bin
+ dosym ${BASE}/realplay /opt/bin
+
+ # NS plugin
+ for b in /opt/netscape /usr/lib/mozilla /usr/lib/nsbrowser
+ do
+ if [ -d ${b} ] ; then
+ dodir ${b}/plugins
+ dosym ${BASE}/rpnp.so ${b}/plugins
+ fi
+ done
+
+ # Desktop menu entry ; KDE, Gnome
+ if use kde ; then
+ insinto ${KDEDIR}/share/applnk/Multimedia
+ doins ${FILESDIR}/realplayer.desktop
+ fi
+ if use gnome ; then
+ # Needs to be tested by someone who actually *has* gnome
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/realplayer.desktop
+ fi
+
+ # Mimetypes - Intentionally left blank (for now)
+ # Better not use the provided scripts from Real, they are outdated
+ # See ${BASE}/mimeinfo for the correct mimetypes if you need them
+}
+
+pkg_postinst() {
+ echo
+ einfo "Finished installing RealPlayer8 into ${BASE}"
+ einfo "You can start the player by running 'realplay'"
+ einfo "You should agree to the terms in ${BASE}/LICENSE or unmerge"
+ echo
+}