summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-16 20:24:49 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-16 20:24:49 +0000
commit2d67d1754534fb46c4a879421b66eb10d2456074 (patch)
tree75c8859f869f1f30a9279925d69bed1170a3eab7 /media-video/xawdecode
parentversion bump for testing (diff)
downloadhistorical-2d67d1754534fb46c4a879421b66eb10d2456074.tar.gz
historical-2d67d1754534fb46c4a879421b66eb10d2456074.tar.bz2
historical-2d67d1754534fb46c4a879421b66eb10d2456074.zip
new tv viewing application
Diffstat (limited to 'media-video/xawdecode')
-rw-r--r--media-video/xawdecode/ChangeLog10
-rw-r--r--media-video/xawdecode/files/digest-xawdecode-1.6.71
-rw-r--r--media-video/xawdecode/xawdecode-1.6.7.ebuild72
3 files changed, 83 insertions, 0 deletions
diff --git a/media-video/xawdecode/ChangeLog b/media-video/xawdecode/ChangeLog
new file mode 100644
index 000000000000..31c01a3c26dc
--- /dev/null
+++ b/media-video/xawdecode/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-video/xawdecode
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawdecode/ChangeLog,v 1.1 2003/03/16 20:24:49 seemant Exp $
+
+*xawdecode-1.6.7 (16 Mar 2003)
+
+ 16 Mar 2003; Seemant Kulleen <seemant@gentoo.org> xawdecode-1.6.7.ebuild:
+ new package for TV viewing, thanks to: Christian Loitsch
+ <gentoo-bug@loitsch.org> in bug #9674
+
diff --git a/media-video/xawdecode/files/digest-xawdecode-1.6.7 b/media-video/xawdecode/files/digest-xawdecode-1.6.7
new file mode 100644
index 000000000000..6ff37a1c0a62
--- /dev/null
+++ b/media-video/xawdecode/files/digest-xawdecode-1.6.7
@@ -0,0 +1 @@
+MD5 03f2836ea1820f13c8db5c1b07c329e7 xawdecode-1.6.7.tar.gz 481227
diff --git a/media-video/xawdecode/xawdecode-1.6.7.ebuild b/media-video/xawdecode/xawdecode-1.6.7.ebuild
new file mode 100644
index 000000000000..f928a1a20c51
--- /dev/null
+++ b/media-video/xawdecode/xawdecode-1.6.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawdecode/xawdecode-1.6.7.ebuild,v 1.1 2003/03/16 20:24:49 seemant Exp $
+
+inherit eutils
+
+IUSE="alsa jpeg dga encode"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TV application for the bttv driver allowing decoding"
+HOMEPAGE="http://xawdecode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xawdecode/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-apps/sed-4.0.5"
+
+RDEPEND="virtual/x11
+ media-libs/divx4linux
+ media-video/avifile
+ encode? ( media-sound/lame )
+ jpeg? ( media-libs/jpeg )
+ alsa? ( media-libs/alsa-lib )"
+
+
+src_compile() {
+ local myconf
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
+
+ use jpeg \
+ && myconf="${myconf} --enable-jpeg" \
+ || myconf="${myconf} --disable-jpeg"
+
+ use dga \
+ && myconf="${myconf} --enable-xfree-ext" \
+ || myconf="${myconf} --disable-xfree-ext"
+
+
+ # if lame is installed xawdecode will use it (there's no configure-flag)
+ # if lirc is installed it will also be used
+ # the same goes for ffmpeg libraries (not media-video/ffmpeg)
+ # (don't know how to install them)
+
+ econf ${myconf} || die
+
+ emake PERF_FLAGS2="${CFLAGS}" || die
+}
+
+src_install() {
+
+ sed -i \
+ "s:^SUBDIRS.*:SUBDIRS = alevt src:" Makefile
+
+ insinto /usr/X11R6/lib/X11/fonts/misc
+ doins font/led-fixed.pcf
+
+ einstall \
+ ROOT=${D} || die
+
+ dodoc COPYING ChangeLog
+ dodoc FAQ* README.* lisez-moi*
+ dodoc xawdecoderc.sample
+
+}
+
+pkg_postinst() {
+ einfo "Please note that this ebuild created a suid-binary: /usr/bin/v4l-conf"
+}