summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-08-06 15:39:59 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-08-06 15:39:59 +0000
commit7160827373233da392c20e415682b4fc88af6a26 (patch)
tree7816e7fe77514cc88be8e7dc5627ba0109fd6d26 /media-video/xine-ui
parentsandboxing bandaid fix (diff)
downloadhistorical-7160827373233da392c20e415682b4fc88af6a26.tar.gz
historical-7160827373233da392c20e415682b4fc88af6a26.tar.bz2
historical-7160827373233da392c20e415682b4fc88af6a26.zip
new xine version stuff continues
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog8
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.131
-rw-r--r--media-video/xine-ui/xine-ui-0.9.13.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 5b8b42525952..1587c406fcca 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.16 2002/07/31 16:13:34 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.17 2002/08/06 15:39:59 lostlogic Exp $
+
+*xine-ui-0.9.13 (06 Aug 2002)
+
+ 06 Aug 2002; Brandon Low <lostlogic@gentoo.org> xine-ui-0.9.13.ebuild:
+
+ New xine version, enjoy.
*xine-ui-0.9.12-r1 (31 Jul 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.13 b/media-video/xine-ui/files/digest-xine-ui-0.9.13
new file mode 100644
index 000000000000..d2f85ebf16e8
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.13
@@ -0,0 +1 @@
+MD5 7f7838f90b830ec25b905c8eb0215321 xine-ui-0.9.13.tar.gz 1717501
diff --git a/media-video/xine-ui/xine-ui-0.9.13.ebuild b/media-video/xine-ui/xine-ui-0.9.13.ebuild
new file mode 100644
index 000000000000..3b60aca7d070
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.13.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.13.ebuild,v 1.1 2002/08/06 15:39:59 lostlogic Exp $
+
+inherit libtool || die "I lost my inheritance"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+
+ elibtoolize
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}