summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-21 01:09:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-21 01:09:22 +0000
commite4e6725b36032e4e5e6bdae246ef0dcba0441971 (patch)
treeecfce44e35c810b942f7af3d3d9366701b8e0d6a /media-video/zapping
parentFixed two typos (diff)
downloadhistorical-e4e6725b36032e4e5e6bdae246ef0dcba0441971.tar.gz
historical-e4e6725b36032e4e5e6bdae246ef0dcba0441971.tar.bz2
historical-e4e6725b36032e4e5e6bdae246ef0dcba0441971.zip
removed avi-xmms
Diffstat (limited to 'media-video/zapping')
-rw-r--r--media-video/zapping/files/digest-zapping-0.6.2-r11
-rw-r--r--media-video/zapping/zapping-0.6.2-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-video/zapping/files/digest-zapping-0.6.2-r1 b/media-video/zapping/files/digest-zapping-0.6.2-r1
new file mode 100644
index 000000000000..c00d29b91085
--- /dev/null
+++ b/media-video/zapping/files/digest-zapping-0.6.2-r1
@@ -0,0 +1 @@
+MD5 d589bd132d91eb384eaf5bf6c9e76ccc zapping-0.6.2.tar.bz2 1056406
diff --git a/media-video/zapping/zapping-0.6.2-r1.ebuild b/media-video/zapping/zapping-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..715ade78cb70
--- /dev/null
+++ b/media-video/zapping/zapping-0.6.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Tools team <tools@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/zapping/zapping-0.6.2-r1.ebuild,v 1.1 2002/05/21 01:09:22 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Zapping is a TV- and VBI- viewer for the Gnome environment."
+SRC_URI="http://telia.dl.sourceforge.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://zapping.sourceforge.net"
+
+DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-base/libglade-0.17-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ dev-libs/libunicode"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use pam && myconf="${myconf} --enable-pam"
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ econf ${myconf} || die
+
+ mv src/Makefile src/Makefile.orig
+ sed -e \
+ "s:\(INCLUDES = \$(COMMON_INCLUDES)\):\1 -I/usr/include/libglade-1.0 -I/usr/include/gdk-pixbuf-1.0:" \
+ src/Makefile.orig > src/Makefile
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ PACKAGE_LIB_DIR=${D}/usr/lib/zapping \
+ PACKAGE_PIXMAPS_DIR=${D}/usr/share/pixmaps/zapping \
+ PLUGIN_DEFAULT_DIR=${D}/usr/lib/zapping/plugins \
+ || die
+
+ rm ${D}/usr/bin/zapzilla
+ dosym /usr/bin/zapping /usr/bin/zapzilla
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}