summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-15 21:47:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-15 21:47:41 +0000
commit38d4969971a4cccf4b4c54f989c95ceb0de15646 (patch)
treea466a7a4a98c2256eff382ce2f50c3d378dbe178 /media-video
parentPatched libmpeg3 to behave like a library finally (diff)
downloadhistorical-38d4969971a4cccf4b4c54f989c95ceb0de15646.tar.gz
historical-38d4969971a4cccf4b4c54f989c95ceb0de15646.tar.bz2
historical-38d4969971a4cccf4b4c54f989c95ceb0de15646.zip
Version bump
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog9
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.0_pre41
-rw-r--r--media-video/transcode/transcode-0.5.3.ebuild6
-rw-r--r--media-video/transcode/transcode-0.6.0_pre4.ebuild48
4 files changed, 59 insertions, 5 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index bf7feee9d973..1e6529f04437 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.1 2002/04/02 22:31:39 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.2 2002/04/15 21:47:41 seemant Exp $
+
+*transcode-0.6.0_pre4 (15 Apr 2002)
+
+ 15 Apr 2002; Seemant Kulleen <seemant@gentoo.org> transcode-0.6.0_pre4.ebuild
+ files/digest-transcode-0.6.0_pre4 :
+
+ Version bump.
*transcode-0.5.3 (2 Apr 2002)
diff --git a/media-video/transcode/files/digest-transcode-0.6.0_pre4 b/media-video/transcode/files/digest-transcode-0.6.0_pre4
new file mode 100644
index 000000000000..b29010071033
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.0_pre4
@@ -0,0 +1 @@
+MD5 c0f9fdf944ed17312f224d3e5ac7d2b1 transcode-0.6.0pre4.tgz 1788981
diff --git a/media-video/transcode/transcode-0.5.3.ebuild b/media-video/transcode/transcode-0.5.3.ebuild
index 35f6ec154ad2..0d590778f432 100644
--- a/media-video/transcode/transcode-0.5.3.ebuild
+++ b/media-video/transcode/transcode-0.5.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.5.3.ebuild,v 1.2 2002/04/05 08:44:03 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.5.3.ebuild,v 1.3 2002/04/15 21:47:41 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="video stream processing tool"
@@ -11,9 +11,7 @@ HOMEPAGE="http://divx.euro.ru/"
# note: transcode can use pretty much any media-related package ever written as a plugin.
# an exhaustive dep list would make me add about 20-30 packages to portage. perhaps another time :-)
-DEPEND="sys-devel/gcc
- virtual/glibc
- >=media-sound/lame-3.89
+DEPEND=">=media-sound/lame-3.89
media-libs/libdv
media-libs/libmpeg3
>=media-video/avifile-0.6"
diff --git a/media-video/transcode/transcode-0.6.0_pre4.ebuild b/media-video/transcode/transcode-0.6.0_pre4.ebuild
new file mode 100644
index 000000000000..01887efbb174
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.0_pre4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Dan Armak <danarmak@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/media-video/transcode/transcode-0.5.3.ebuild,v 1.2 2002/04/05 08:44:03 verwilst Exp
+
+P=transcode-0.6.0pre4
+S=${WORKDIR}/${P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${P}.tgz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+DEPEND="media-libs/libdv
+ media-libs/libsdl
+ =x11-libs/gtk+-1.2*
+ >=media-video/avifile-0.6
+ dvd? ( media-libs/libdvdread )
+ lame? ( >=media-sound/lame-3.89 )
+ libmpeg3?( media-libs/libmpeg3 )
+ quicktime? ( media-libs/quicktime4linux )"
+
+src_compile() {
+
+ local myconf
+
+ use lame \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use libmpeg3 \
+ && myconf="${myconf} --with-libmpeg3"
+
+ ./configure \
+ --prefix=/usr || die
+
+ emake all || die
+
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+}