summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-12 15:46:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-12 15:46:23 +0000
commit9167f0aa781b525df1797367b39275b3668d303e (patch)
treeb318f602f5d3529666272e9d2e15afeeae50684b /media-video
parentNew avifile release masked for compilation failure (diff)
downloadhistorical-9167f0aa781b525df1797367b39275b3668d303e.tar.gz
historical-9167f0aa781b525df1797367b39275b3668d303e.tar.bz2
historical-9167f0aa781b525df1797367b39275b3668d303e.zip
New version
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/ChangeLog8
-rw-r--r--media-video/avifile/avifile-0.7.20020412.ebuild92
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.200204121
3 files changed, 100 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index e5cd1d215eb8..1e9d0ad0d26c 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.3 2002/03/29 01:58:50 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.4 2002/04/12 15:46:23 seemant Exp $
+
+*avifile-0.7.20020412 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> avifile-0.7.20020412.ebuild:
+
+ New release, and they keep changing the naming scheme -- aaarrgh
*avifile-0.6.0.20011220-r1 (28 Mar 2002)
diff --git a/media-video/avifile/avifile-0.7.20020412.ebuild b/media-video/avifile/avifile-0.7.20020412.ebuild
new file mode 100644
index 000000000000..76a9e9f5b1e6
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.20020412.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.20020412.ebuild,v 1.1 2002/04/12 15:46:23 seemant Exp $
+
+MY_P=${PN}${PV}
+MY_P=${MY_P/.2/-2}
+MY_S=${MY_P/avifile-/avifile}
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tar.gz"
+HOMEPAGE="http://divx.euro.ru/"
+
+DEPEND=">=media-libs/divx4linux-20011025
+ media-libs/jpeg
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ avi? ( media-libs/win32codecs )
+ qt? ( =x11-libs/qt-2* )
+ nas? ( >=media-libs/nas-1.4.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+
+src_compile() {
+
+ local myconf
+
+ use mmx && myconf="--enable-x86opt"
+ use sse && myconf="--enable-x86opt"
+ use 3dnow && myconf="--enable-x86opt"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=/usr/qt/2" \
+ || myconf="${myconf} --disable-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde --with-extra-libraries=/usr/kde/2" \
+ && LDFLAGS="${LDFLAGS} -L/usr/kde/2/lib" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use avi \
+ && myconf="${myconf} --enable-win32" \
+ || myconf="${myconf} --disable-win32"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ use lame \
+ && myconf="${myconf} --enable-lame-bin" \
+ || myconf="${myconf} --disable-lame-bin"
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+
+ ./configure --prefix=/usr \
+ --enable-release \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ ${myconf} || die
+
+# cp Makefile Makefile.orig
+# sed -e "s:/usr/lib/win32:${D}/usr/lib/win32:" \
+# Makefile.orig > Makefile
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.7.20020412 b/media-video/avifile/files/digest-avifile-0.7.20020412
new file mode 100644
index 000000000000..98c593299a7f
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.20020412
@@ -0,0 +1 @@
+MD5 aeeb8d7191257dbd8055161244ee5c03 avifile0.7-20020412.tar.gz 2089763