summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-05 04:58:00 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-05 04:58:00 +0000
commitcf8df1cc254caf388907b4ef5c565e87d4c65162 (patch)
treea6004a7fe90c1d572dad3e85b733f592d273c7e4 /media-video
parentInitial Release of ecasound. (diff)
downloadhistorical-cf8df1cc254caf388907b4ef5c565e87d4c65162.tar.gz
historical-cf8df1cc254caf388907b4ef5c565e87d4c65162.tar.bz2
historical-cf8df1cc254caf388907b4ef5c565e87d4c65162.zip
Version bump. Many bug fixes.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/ChangeLog8
-rw-r--r--media-video/avifile/avifile-0.7.14.20020802.ebuild85
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.14.200208021
3 files changed, 93 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index 0460127bde2f..d4c87492e9db 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.15 2002/06/24 20:15:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.16 2002/08/05 04:57:58 raker Exp $
+
+*avifile-0.7.14.20020802 (04 Aug 2002)
+
+ 04 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ avifile-0.7.14.20020802.ebuild, files/digest-avifile-0.7.14.2020802 :
+ Version bump. Many bug fixes.
*avifile-0.7.7.20020523 (25 Jun 2002)
diff --git a/media-video/avifile/avifile-0.7.14.20020802.ebuild b/media-video/avifile/avifile-0.7.14.20020802.ebuild
new file mode 100644
index 000000000000..7d10757fbce5
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.14.20020802.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.14.20020802.ebuild,v 1.1 2002/08/05 04:57:59 raker Exp $
+
+MY_P=${P/.200/-200}
+MY_S=${PN}0.7-0.7.14
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+DEPEND=">=media-libs/divx4linux-20020418
+ media-libs/jpeg
+ media-libs/win32codecs
+ qt? ( >=x11-libs/qt-3.0.3 )
+ nas? ( >=media-libs/nas-1.4.2 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+SLOT="0.7"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+
+ einfo "${S}"
+
+ local myconf=""
+ local kdepre=""
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ use kde \
+ && ( \
+ myconf="${myconf} --enable-kde" \
+ && LDFLAGS="${LDFLAGS} -L${KDEDIR}/lib" \
+ && myconf="${myconf} --with-extra-libraries=${KDEDIR}" \
+ ) || (
+ myconf="${myconf} --disable-kde" \
+ && LDFLAGS="${LDFLAGS}"
+ )
+
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
diff --git a/media-video/avifile/files/digest-avifile-0.7.14.20020802 b/media-video/avifile/files/digest-avifile-0.7.14.20020802
new file mode 100644
index 000000000000..7c8ad2ddbd6f
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.14.20020802
@@ -0,0 +1 @@
+MD5 78f54032f22f2b780f306bfafc14e143 avifile-0.7.14-20020802.tgz 2394408