summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 23:25:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 23:25:21 +0000
commitba1d507c399a52bbcddb66fc02b1068fb43301af (patch)
tree4934509569ed7110715ef781350ccf6f6efb27f9 /net-analyzer/bsnmp/bsnmp-1.11a.ebuild
parentAdd ~x86-fbsd keyword. (diff)
downloadhistorical-ba1d507c399a52bbcddb66fc02b1068fb43301af.tar.gz
historical-ba1d507c399a52bbcddb66fc02b1068fb43301af.tar.bz2
historical-ba1d507c399a52bbcddb66fc02b1068fb43301af.zip
Initial import from gentoo-alt overlay, SNMP daemon for FreeBSD. Not yet fixed to work on Linux, so just ~x86-fbsd.
Package-Manager: portage-2.1_rc2
Diffstat (limited to 'net-analyzer/bsnmp/bsnmp-1.11a.ebuild')
-rw-r--r--net-analyzer/bsnmp/bsnmp-1.11a.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/bsnmp/bsnmp-1.11a.ebuild b/net-analyzer/bsnmp/bsnmp-1.11a.ebuild
new file mode 100644
index 000000000000..11bf61993899
--- /dev/null
+++ b/net-analyzer/bsnmp/bsnmp-1.11a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bsnmp/bsnmp-1.11a.ebuild,v 1.1 2006/05/22 23:25:21 flameeyes Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Mini-SNMP Daemon and Library"
+HOMEPAGE="http://people.freebsd.org/~harti/"
+SRC_URI="http://people.freebsd.org/~harti/bsnmp/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE="tcpd"
+
+DEPEND="dev-libs/libbegemot
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${PN}-1.10-gcc34.patch"
+}
+
+src_compile() {
+ if use elibc_glibc; then
+ # bsnmp is bsd-based, without this it will fail
+ append-flags "-D_BSD_SOURCE"
+ fi
+
+ filter-flags -fno-inline
+
+ econf \
+ --with-libbegemot=/usr \
+ $(use_with tcpd tcpwrappers) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+}